summaryrefslogtreecommitdiff
path: root/media-sound/soundconverter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /media-sound/soundconverter
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/Manifest2
-rw-r--r--media-sound/soundconverter/soundconverter-3.0.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index ad381f807df1..216d797cf101 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1,3 +1,5 @@
DIST soundconverter-3.0.0-beta1.tar.xz 196916 BLAKE2B 82832a151e030cbd2be129fe7f4dcd92430aadc71b163c3800cc2108f502020561e2c74291cbb25050ed42bd9d71fdfe310f107af84f612711554cf3e32fd07b SHA512 a27a2c7b4156a6d6c682424c5fa64a4dd82537b1dbfa8176fa39fbfc4d139a21b7dd042de80d088333c0aef0042a76940ab8da5d9708b6aac3399b32b7408f09
+DIST soundconverter-3.0.0.tar.xz 201548 BLAKE2B bdca42d22d2e497b807149dcd5c8f911519b71dc7e836ad359831d0b7cd2241f58f8f9f60fa4580e2f038528e9c249dfa8a811d1681d0c8dead2c53e0f58f7ce SHA512 6f5518711c76e7748447805dbf16ac8622c5041c3f3cac2de6f31968aab4eff43a2fde2da48c47d12093ce1732208923d83d57b6a97ea99fbf882dfef239a62d
+EBUILD soundconverter-3.0.0.ebuild 1801 BLAKE2B 91a1ca75bcbe11ff09266cc3a465a954bd8fd44feef3f956e22c59949ccc11ca8da20f8cf5b42a2f7ce9dae36a6bc6dc10eda1c823aa76f37045f355c253a6ae SHA512 7ccf4fdc7bc1864cd9b29c8d6e019f7c1884bcebcf7e4fd087fe43249e236671df05accbf1ca8e2af7cd71553915e49d179902cc635b9d03aafd747abb245c01
EBUILD soundconverter-3.0.0_beta1.ebuild 1723 BLAKE2B f23e65f31ea2707e8bced4de1a19813c5d0b140aa5e38c8d6b0dfa46a2a92a771b3d590e0479e88d2239eb6b95f126068e959fd8f1821a258682db02bb9d3e9c SHA512 703175800399bb19fed41bee82a0e839a10f0c1d36f9da5c7854d8d030788f246ffb449765e20651e42fa050e966e1e45c1ca01cbdd0f4002e6434f8777dbc16
MISC metadata.xml 422 BLAKE2B c38fb6712043983aeaccb925b572fe26156e10776ff00ff454fd215ddedb0751d3c5f5a973725da4e765907f3c9d0ffe6f4062650a7afa2e092cd9b6930219b2 SHA512 5dc640470aea1b45a59fbc757c1fc57a287a733c7e924cecec2dfda988caf313aa9863e86bc4a538565d9e574207654e62ec2071d03f647d21ef6dff38d15732
diff --git a/media-sound/soundconverter/soundconverter-3.0.0.ebuild b/media-sound/soundconverter/soundconverter-3.0.0.ebuild
new file mode 100644
index 000000000000..caa319caa263
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-3.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="http://soundconverter.org/"
+MY_PV="${PV/_/-}"
+SRC_URI="https://launchpad.net/${PN}/trunk/${MY_PV}/+download/${PN}-${MY_PV}.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="aac flac libnotify mp3 ogg opus vorbis"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/gobject-introspection:=
+ x11-libs/gtk+:3[introspection]
+ media-libs/gstreamer:1.0[introspection]
+"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/pango[introspection]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ libnotify? ( x11-libs/libnotify[introspection] )
+
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+RESTRICT="test" # broken pot files list in 3.0.0 release, making src_test fallback to "make test" which fails
+
+src_prepare() {
+ python_fix_shebang .
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
+}