summaryrefslogtreecommitdiff
path: root/media-sound/sfc/sfc-0.018-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/sfc/sfc-0.018-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/sfc/sfc-0.018-r1.ebuild')
-rw-r--r--media-sound/sfc/sfc-0.018-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-sound/sfc/sfc-0.018-r1.ebuild b/media-sound/sfc/sfc-0.018-r1.ebuild
new file mode 100644
index 000000000000..58a1f87d34c6
--- /dev/null
+++ b/media-sound/sfc/sfc-0.018-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="SoundFontCombi is an opensource software pseudo synthesizer"
+HOMEPAGE="http://personal.telefonica.terra.es/web/soudfontcombi/"
+SRC_URI="http://personal.telefonica.terra.es/web/soudfontcombi/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND="
+ media-libs/alsa-lib
+ x11-libs/fltk:1"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "/CXXFLAGS/s:-O3:${CXXFLAGS}:" configure.in || die
+ epatch_user
+ eautoreconf
+}