summaryrefslogtreecommitdiff
path: root/media-sound/sexypsf/sexypsf-0.4.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/sexypsf/sexypsf-0.4.8.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/sexypsf/sexypsf-0.4.8.ebuild')
-rw-r--r--media-sound/sexypsf/sexypsf-0.4.8.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/media-sound/sexypsf/sexypsf-0.4.8.ebuild b/media-sound/sexypsf/sexypsf-0.4.8.ebuild
index 427a0518e2ca..7f7bf7f7e776 100644
--- a/media-sound/sexypsf/sexypsf-0.4.8.ebuild
+++ b/media-sound/sexypsf/sexypsf-0.4.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,19 +11,25 @@ SRC_URI="http://projects.raphnet.net/sexypsf/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND="sys-libs/zlib"
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
-src_compile() {
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.8-Makefile.patch
+ "${FILESDIR}"/${PN}-0.4.8-fno-common.patch
+)
+
+src_configure() {
tc-export CC
- cd Linux || die
- emake
+}
+
+src_compile() {
+ emake -C Linux
}
src_install() {
dobin Linux/sexypsf
- dodoc Docs/*
+ dodoc -r Docs/.
}