summaryrefslogtreecommitdiff
path: root/media-sound/sexypsf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/sexypsf/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/sexypsf/files')
-rw-r--r--media-sound/sexypsf/files/sexypsf-0.4.8-Makefile.patch12
-rw-r--r--media-sound/sexypsf/files/sexypsf-0.4.8-fno-common.patch102
2 files changed, 114 insertions, 0 deletions
diff --git a/media-sound/sexypsf/files/sexypsf-0.4.8-Makefile.patch b/media-sound/sexypsf/files/sexypsf-0.4.8-Makefile.patch
new file mode 100644
index 000000000000..348c392f3574
--- /dev/null
+++ b/media-sound/sexypsf/files/sexypsf-0.4.8-Makefile.patch
@@ -0,0 +1,12 @@
+--- a/Linux/Makefile
++++ b/Linux/Makefile
+@@ -28,9 +28,3 @@
+
+ clean:
+ ${RM} *.o ../*.o ../spu/*.o sexypsf
+-
+-../%.o: ../%.c
+- ${CC} ${CFLAGS} -c -o $@ $<
+-
+-%.o: %.c
+- ${CC} ${CFLAGS} -c -o $@ $<
diff --git a/media-sound/sexypsf/files/sexypsf-0.4.8-fno-common.patch b/media-sound/sexypsf/files/sexypsf-0.4.8-fno-common.patch
new file mode 100644
index 000000000000..fd0d96525b33
--- /dev/null
+++ b/media-sound/sexypsf/files/sexypsf-0.4.8-fno-common.patch
@@ -0,0 +1,102 @@
+--- a/PsxCounters.c
++++ b/PsxCounters.c
+@@ -20,6 +20,9 @@
+
+ #include "PsxCommon.h"
+
++psxCounter psxCounters[5];
++u32 psxNextCounter, psxNextsCounter;
++
+ static int cnts = 4;
+ static u32 last=0;
+
+--- a/PsxCounters.h
++++ b/PsxCounters.h
+@@ -24,9 +24,9 @@
+ u32 sCycle, Cycle, rate, interrupt;
+ } psxCounter;
+
+-psxCounter psxCounters[5];
++extern psxCounter psxCounters[5];
+
+-u32 psxNextCounter, psxNextsCounter;
++extern u32 psxNextCounter, psxNextsCounter;
+
+ void psxRcntInit();
+ void psxRcntUpdate();
+--- a/PsxMem.c
++++ b/PsxMem.c
+@@ -21,6 +21,12 @@
+
+ #include "PsxCommon.h"
+
++s8 *psxM;
++s8 *psxP;
++s8 *psxR;
++s8 *psxH;
++char **psxMemLUT;
++
+ void LoadPSXMem(u32 address, s32 length, char *data)
+ {
+ //printf("%08x %08x\n",address,length);
+--- a/PsxMem.h
++++ b/PsxMem.h
+@@ -41,21 +41,21 @@
+ }
+ #endif
+
+-s8 *psxM;
++extern s8 *psxM;
+ #define psxMu32(mem) (*(u32*)&psxM[(mem) & 0x1fffff])
+
+-s8 *psxP;
+-s8 *psxR;
++extern s8 *psxP;
++extern s8 *psxR;
+ #define psxRu32(mem) (*(u32*)&psxR[(mem) & 0x7ffff])
+
+-s8 *psxH;
++extern s8 *psxH;
+
+ #define psxHu8(mem) (*(u8*) &psxH[(mem) & 0xffff])
+
+ #define psxHu16(mem) (*(u16*)&psxH[(mem) & 0xffff])
+ #define psxHu32(mem) (*(u32*)&psxH[(mem) & 0xffff])
+
+-char **psxMemLUT;
++extern char **psxMemLUT;
+
+ #define PSXM(mem) (psxMemLUT[(mem) >> 16] == 0 ? NULL : (void*)(psxMemLUT[(mem) >> 16] + ((mem) & 0xffff)))
+
+--- a/R3000A.c
++++ b/R3000A.c
+@@ -22,6 +22,9 @@
+
+ #include "PsxCommon.h"
+
++R3000Acpu *psxCpu;
++psxRegisters psxRegs;
++
+ int psxInit() {
+
+ psxCpu = &psxInt;
+--- a/R3000A.h
++++ b/R3000A.h
+@@ -32,7 +32,7 @@
+ void (*Shutdown)();
+ } R3000Acpu;
+
+-R3000Acpu *psxCpu;
++extern R3000Acpu *psxCpu;
+ extern R3000Acpu psxInt;
+
+ typedef union {
+@@ -68,7 +68,7 @@
+ u32 interrupt;
+ } psxRegisters;
+
+-psxRegisters psxRegs;
++extern psxRegisters psxRegs;
+
+ #define _i32(x) (s32)x
+ #define _u32(x) (u32)x