summaryrefslogtreecommitdiff
path: root/media-sound/setmixer/setmixer-19941227_p1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /media-sound/setmixer/setmixer-19941227_p1.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'media-sound/setmixer/setmixer-19941227_p1.ebuild')
-rw-r--r--media-sound/setmixer/setmixer-19941227_p1.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/media-sound/setmixer/setmixer-19941227_p1.ebuild b/media-sound/setmixer/setmixer-19941227_p1.ebuild
index 1ae45173a460..5a6817684f7a 100644
--- a/media-sound/setmixer/setmixer-19941227_p1.ebuild
+++ b/media-sound/setmixer/setmixer-19941227_p1.ebuild
@@ -1,40 +1,42 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_PV="27DEC94ds1"
DEB_REV="1"
DESCRIPTION="A commandline mixer"
-HOMEPAGE="http://packages.debian.org/unstable/sound/setmixer"
-SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}.orig.tar.gz
+HOMEPAGE="https://packages.debian.org/unstable/sound/setmixer"
+SRC_URI="
+ mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}.orig.tar.gz
mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}-${DEB_REV}.diff.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86"
-IUSE=""
-S=${WORKDIR}/${PN}-${MY_PV}.orig
+S="${WORKDIR}/${PN}-${MY_PV}.orig"
-src_unpack() {
- unpack ${A}
- epatch "${DISTDIR}"/${PN}_${MY_PV}-${DEB_REV}.diff.gz
-}
+PATCHES=( "${WORKDIR}"/${PN}_${MY_PV}-${DEB_REV}.diff )
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" setmixer || die "emake failed."
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" setmixer
}
src_install() {
dobin setmixer
+
dodoc README setmixer.lsm
doman setmixer.1
+
insinto /etc
doins debian/setmixer.conf
+
newinitd "${FILESDIR}"/setmixer.rc setmixer
}