summaryrefslogtreecommitdiff
path: root/media-sound/schismtracker/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
commit5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (patch)
tree5c040bbee9184b24f26b05031a2448e62f6df38a /media-sound/schismtracker/files
parent2c4066122b66fa1eb3e37846f9a6e14529a553d8 (diff)
gentoo auto-resync : 02:12:2022 - 08:55:37
Diffstat (limited to 'media-sound/schismtracker/files')
-rw-r--r--media-sound/schismtracker/files/schismtracker-20221201-bashism.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/schismtracker/files/schismtracker-20221201-bashism.patch b/media-sound/schismtracker/files/schismtracker-20221201-bashism.patch
new file mode 100644
index 000000000000..64cad709efe0
--- /dev/null
+++ b/media-sound/schismtracker/files/schismtracker-20221201-bashism.patch
@@ -0,0 +1,29 @@
+https://github.com/schismtracker/schismtracker/pull/340
+
+From 5f2f594b6a4055318fa31d3c0cd6ecc8dc3666f7 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 2 Dec 2022 01:39:06 +0000
+Subject: [PATCH] Fix bashism in configure.ac sdl2-config check
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+--- a/configure.ac
++++ b/configure.ac
+@@ -63,7 +63,7 @@ AC_C_BIGENDIAN
+ dnl Check for SDL libs
+ AC_CHECK_TOOL([SDL_CONFIG], [sdl2-config])
+ AC_SUBST(SDL_CONFIG)
+-if test "x$SDL_CONFIG" == "x"; then
++if test "x$SDL_CONFIG" = "x"; then
+ AC_MSG_ERROR([*** sdl2-config not found.])
+ fi
+ AS_VERSION_COMPARE([$($SDL_CONFIG --version)], [2.0.5], [AC_MSG_ERROR([*** SDL version >= 2.0.5 not found.])])
+