summaryrefslogtreecommitdiff
path: root/media-sound/rexima/files/rexima-1.4-makefile.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 03:08:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 03:08:54 +0100
commitcdb747b791914a30c287a3a8e33d1b635e431707 (patch)
treebe22ab4ebfae7f170acb577486d0edc7e6d14279 /media-sound/rexima/files/rexima-1.4-makefile.patch
parent496936ff0f7db69d1f7317341230acb866e3c330 (diff)
gentoo auto-resync : 30:07:2022 - 03:08:54
Diffstat (limited to 'media-sound/rexima/files/rexima-1.4-makefile.patch')
-rw-r--r--media-sound/rexima/files/rexima-1.4-makefile.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-sound/rexima/files/rexima-1.4-makefile.patch b/media-sound/rexima/files/rexima-1.4-makefile.patch
new file mode 100644
index 000000000000..9c70493b4cd5
--- /dev/null
+++ b/media-sound/rexima/files/rexima-1.4-makefile.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,9 @@
+ # Makefile - makefile for rexima
+
+-CC=gcc
+-CFLAGS=-O -Wall
++PKG_CONFIG ?= pkg-config
++CFLAGS += -Wall
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags ncurses)
++LDLIBS = $(shell $(PKG_CONFIG) --libs ncurses)
+
+ # Set BINDIR to directory for binary,
+ # MANDIR to directory for man page.
+@@ -16,9 +18,6 @@
+
+ all: rexima
+
+-rexima: rexima.o
+- $(CC) $(CFLAGS) -o rexima rexima.o -lncurses
+-
+ installdirs:
+ /bin/sh ./mkinstalldirs $(BINDIR) $(MANDIR)
+