summaryrefslogtreecommitdiff
path: root/media-sound/qsynth/qsynth-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /media-sound/qsynth/qsynth-9999.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'media-sound/qsynth/qsynth-9999.ebuild')
-rw-r--r--media-sound/qsynth/qsynth-9999.ebuild35
1 files changed, 21 insertions, 14 deletions
diff --git a/media-sound/qsynth/qsynth-9999.ebuild b/media-sound/qsynth/qsynth-9999.ebuild
index 7866d934551b..e7d76b663936 100644
--- a/media-sound/qsynth/qsynth-9999.ebuild
+++ b/media-sound/qsynth/qsynth-9999.ebuild
@@ -1,18 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop qmake-utils xdg-utils git-r3 autotools
+inherit cmake desktop qmake-utils xdg-utils
DESCRIPTION="Qt application to control FluidSynth"
HOMEPAGE="https://qsynth.sourceforge.io/"
-EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
IUSE="+alsa debug jack pulseaudio"
-KEYWORDS=""
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
BDEPEND="
dev-qt/linguist-tools:5
@@ -26,24 +34,23 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-REQUIRED_USE="|| ( alsa jack pulseaudio )"
+PATCHES=( "${FILESDIR}/${PN}-0.9.0-cmake-no-git-version.patch" )
src_prepare() {
- default
- eautoreconf
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
}
src_configure() {
- sed -e "/@gzip.*mandir)\/man1/d" -i Makefile.in || die
- econf \
- $(use_enable debug)
-
- eqmake5 ${PN}.pro -o ${PN}.mak
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ )
+ cmake_src_configure
}
src_install() {
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- einstalldocs
+ cmake_src_install
# The desktop file is invalid, and we also change the command
# depending on useflags