summaryrefslogtreecommitdiff
path: root/media-sound/qpwgraph/qpwgraph-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /media-sound/qpwgraph/qpwgraph-0.6.2.ebuild
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'media-sound/qpwgraph/qpwgraph-0.6.2.ebuild')
-rw-r--r--media-sound/qpwgraph/qpwgraph-0.6.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-sound/qpwgraph/qpwgraph-0.6.2.ebuild b/media-sound/qpwgraph/qpwgraph-0.6.2.ebuild
new file mode 100644
index 000000000000..37b4e0ba45ae
--- /dev/null
+++ b/media-sound/qpwgraph/qpwgraph-0.6.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="PipeWire Graph Qt GUI Interface"
+HOMEPAGE="https://gitlab.freedesktop.org/rncbc/qpwgraph"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/rncbc/qpwgraph"
+else
+ SRC_URI="https://gitlab.freedesktop.org/rncbc/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="alsa trayicon qt6 wayland"
+
+BDEPEND="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+"
+DEPEND="
+ media-video/pipewire:=
+ alsa? ( media-libs/alsa-lib )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,widgets,xml,network]
+ dev-qt/qtsvg:6
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ALSA_MIDI=$(usex alsa)
+ -DCONFIG_SYSTEM_TRAY=$(usex trayicon)
+ -DCONFIG_WAYLAND=$(usex wayland)
+ -DCONFIG_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}