summaryrefslogtreecommitdiff
path: root/media-sound/pwavecat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/pwavecat/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/pwavecat/files')
-rw-r--r--media-sound/pwavecat/files/pwavecat-0.4.5-overflow.patch27
-rw-r--r--media-sound/pwavecat/files/pwavecat-0.4.5.diff27
2 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/pwavecat/files/pwavecat-0.4.5-overflow.patch b/media-sound/pwavecat/files/pwavecat-0.4.5-overflow.patch
new file mode 100644
index 000000000000..f3d54221bc7d
--- /dev/null
+++ b/media-sound/pwavecat/files/pwavecat-0.4.5-overflow.patch
@@ -0,0 +1,27 @@
+diff --git a/parts.c b/parts.c
+index 670d0d5..a59ad98 100644
+--- a/parts.c
++++ b/parts.c
+@@ -338,10 +338,10 @@ if(! file_header)
+ return 0;
+ }
+
+-strcpy(file_header -> main_chunk, "RIFF");
++memcpy(file_header -> main_chunk, "RIFF", 4);
+ file_header -> length = length + header_size - 8;
+-strcpy(file_header -> chunk_type, "WAVE");
+-strcpy(file_header -> sub_chunk, "fmt "); // watch out the zero termination overwrites next var
++memcpy(file_header -> chunk_type, "WAVE", 4);
++memcpy(file_header -> sub_chunk, "fmt ", 4); // watch out the zero termination overwrites next var
+ file_header -> length_chunk = 16; //always 16
+ file_header -> format = 1; //PCM
+ file_header -> modus = modus; // stereo
+@@ -349,7 +349,7 @@ file_header -> sample_fq = sample_fq; // 44100, 48000, etc...
+ file_header -> byte_p_sec = byte_p_sec; // little endian
+ file_header -> byte_p_spl = byte_p_spl; // 4 stereo
+ file_header -> bit_p_spl = bit_p_spl; // 16 bits
+-strcpy(file_header -> data_chunk, "data"); // watch out the zero termination overwrites next var
++memcpy(file_header -> data_chunk, "data", 4); // watch out the zero termination overwrites next var
+ file_header -> data_length = (unsigned long)length;
+
+ if(debug_flag)
diff --git a/media-sound/pwavecat/files/pwavecat-0.4.5.diff b/media-sound/pwavecat/files/pwavecat-0.4.5.diff
new file mode 100644
index 000000000000..abe00c69daec
--- /dev/null
+++ b/media-sound/pwavecat/files/pwavecat-0.4.5.diff
@@ -0,0 +1,27 @@
+diff -Naur pwavecat-0.4.5.orig/Makefile pwavecat-0.4.5/Makefile
+--- pwavecat-0.4.5.orig/Makefile 2005-10-06 15:52:56.000000000 +0200
++++ pwavecat-0.4.5/Makefile 2007-10-06 16:27:25.000000000 +0200
+@@ -15,9 +15,9 @@
+ parts.o
+
+ all:
+- gcc $(CFLAGS) -c $(SRC1)
++ $(CC) $(CFLAGS) -c $(SRC1)
+
+- gcc -o pwavecat $(OBJECT1) $(LIBRARY)
++ $(CC) $(LDFLAGS) -o pwavecat $(OBJECT1) $(LIBRARY)
+
+ # DEPENDENCIES
+ pwavecat.o : pwavecat.c pwavecat.h pwavecat_proto.h parts.h wave_header.h
+diff -Naur pwavecat-0.4.5.orig/pwavecat.h pwavecat-0.4.5/pwavecat.h
+--- pwavecat-0.4.5.orig/pwavecat.h 2005-10-06 15:52:56.000000000 +0200
++++ pwavecat-0.4.5/pwavecat.h 2007-10-06 16:27:50.000000000 +0200
+@@ -27,7 +27,7 @@
+
+ char *input_filename[MAX_FILES];
+
+-#define VERSION "0.4.4"
++#define VERSION "0.4.5"
+
+ #endif /* _PWAVECAT_H_ */
+