summaryrefslogtreecommitdiff
path: root/media-sound/pulsemixer/pulsemixer-1.5.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
commit5adfd733728a4f14df5665f4c2a604a7356e5f19 (patch)
treef2938c4a08576b45508b02481edfec55eac3ac8b /media-sound/pulsemixer/pulsemixer-1.5.1-r2.ebuild
parentfbba40085f5d1591a67b49f5aa48b4071b7560f1 (diff)
gentoo auto-resync : 11:06:2023 - 14:17:09
Diffstat (limited to 'media-sound/pulsemixer/pulsemixer-1.5.1-r2.ebuild')
-rw-r--r--media-sound/pulsemixer/pulsemixer-1.5.1-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/pulsemixer/pulsemixer-1.5.1-r2.ebuild b/media-sound/pulsemixer/pulsemixer-1.5.1-r2.ebuild
new file mode 100644
index 000000000000..54f5ab3fa3ac
--- /dev/null
+++ b/media-sound/pulsemixer/pulsemixer-1.5.1-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and curses mixer for PulseAudio"
+HOMEPAGE="https://github.com/GeorgeFilipkin/pulsemixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GeorgeFilipkin/${PN}"
+else
+ SRC_URI="https://github.com/GeorgeFilipkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-libs/libpulse"