summaryrefslogtreecommitdiff
path: root/media-sound/pulseaudio-modules-bt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-sound/pulseaudio-modules-bt
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-sound/pulseaudio-modules-bt')
-rw-r--r--media-sound/pulseaudio-modules-bt/Manifest3
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild24
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild75
3 files changed, 13 insertions, 89 deletions
diff --git a/media-sound/pulseaudio-modules-bt/Manifest b/media-sound/pulseaudio-modules-bt/Manifest
index 790a609edc97..2d2d8ff3bcd4 100644
--- a/media-sound/pulseaudio-modules-bt/Manifest
+++ b/media-sound/pulseaudio-modules-bt/Manifest
@@ -1,5 +1,4 @@
DIST pulseaudio-13.0.tar.xz 1901768 BLAKE2B 651a80f54525f196bcb036d893fedd4d9f34e10459918281397a45f498c31bff0d0c836f4e64aab5ac2612ffd5a0cab1a41ea710bbee5fd34dfc9ea1236deea9 SHA512 d445b8ccd43029a0ca0e456fc9291a79d3434d6496ead7eb329ab348d5249235e8bde6cf2be68765d8f761452dbe1486fb10c739e40b1e67ed75787bbd24ac0c
DIST pulseaudio-modules-bt-1.4.tar.gz 87558 BLAKE2B 98b21d8fced5b88d59e45ca4fa2505d3606616a8a09dd95eb91e30b0d31c8a0ec7e52e4c2fd1b601130f69a997871064849fa0c8847ec0686fb42a2ccd7ac43b SHA512 390b6ad0931b464a546c6624bec38cc5b6da7084e4defe2045f4164b0c910a9dd6d4327466eb0e53fcfbc78c995cf2e3634a75b67ee2a14f38ed18e31b5d2bce
-EBUILD pulseaudio-modules-bt-1.4.ebuild 2194 BLAKE2B 389cd211299f30b3fa4634bcdec0eb6f1b7152bede7558bcd516b1a80d05a8cdebddfc0904cfffd233eccae54292bf75d5a85ddc7ba335c87bdd1f932390e32f SHA512 a34e4f1956670b72b80712c49dfab5325cb916594e71a9f7c4fc0eedbe8a318a427f12947a771ed83ec065dbbd1deb69b49e366ead93c5f3e817de92e564e550
-EBUILD pulseaudio-modules-bt-9999.ebuild 2063 BLAKE2B b45bfc09796b5c9614ec159ab0f79481009b850aecfe840c94789ac32fd8eac21e9143e2959bfbe1f6e099cf106e4edbbc2dac1f8137ff80d6dbbfc016f8b8fb SHA512 1003a535a6a01464f85ca06cfe9eb20519ed78e0855bc86afc16634f4e3582976738b4d333bf41efcfacde7c8733b363f8cd42dd314468dfa7a0f9ac9cf2c993
+EBUILD pulseaudio-modules-bt-1.4.ebuild 2170 BLAKE2B 9e09eaf4e2ba634bb05c48a8db1a813a201589c7dc41a44653de6d630e03571f5d73c6071ff03dc292218b47881eb9cab717ee71ee61ea1941777021e5d58e56 SHA512 af3d8e0303cd3eec86155cf390fdca9d0ea68000bd6c84f91a772be354a630fc20e06cf4c172ac9a702ec2bef5884f532c78cd2c9fb5c1243f3bc40c03628546
MISC metadata.xml 766 BLAKE2B 3fc16e24b2ecb5212c32ada629f2e8c19c91921333db4de169f0848b6bc63b2001c8e68d7c82765e064f8ecbed10e25bc926ea7c598c09d88d5e474df63ab9bb SHA512 c14a460ddba2b09ecddd6a5f12ca8a888b22bac2b9f606249d466473bde3e6ae5c64ee899e74c5ca10c3708d9a39874dfcbbce84c3ccc383c274ac8cfbde43bc
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
index 56a66ff8e9e3..4b41f381f58c 100644
--- a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
+++ b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils readme.gentoo-r1
+inherit cmake readme.gentoo-r1
DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth"
HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -51,6 +51,14 @@ load-module module-bluetooth-discover
.endif
"
+src_prepare() {
+ cmake_src_prepare
+
+ # pulseaudio headers needed to build
+ rmdir pa/ || die
+ ln -s ../pulseaudio-${PULSE_VER}/ pa || die
+}
+
src_configure() {
local mycmakeargs=(
-DCODEC_AAC_FDK=$(usex fdk "ON" "OFF")
@@ -60,19 +68,11 @@ src_configure() {
-DNATIVE_HEADSET=$(usex native-headset "ON" "OFF")
-DOFONO_HEADSET=$(usex ofono-headset "ON" "OFF")
)
- cmake-utils_src_configure
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # pulseaudio headers needed to build
- rmdir pa/ || die
- ln -s ../pulseaudio-${PULSE_VER}/ pa || die
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
readme.gentoo_create_doc
}
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
deleted file mode 100644
index 5363d6d475a6..000000000000
--- a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit git-r3 cmake-utils readme.gentoo-r1
-
-DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth"
-HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/EHfive/${PN}"
-
-# Ensure it is synced with major pulseaudio version
-# https://github.com/EHfive/pulseaudio-modules-bt/issues/83
-EGIT_OVERRIDE_COMMIT_PULSEAUDIO_PULSEAUDIO="v13.0"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE="fdk +ffmpeg +ldac +native-headset ofono-headset"
-
-DEPEND="
- fdk? ( media-libs/fdk-aac:0= )
- ffmpeg? ( media-video/ffmpeg )
- media-libs/sbc
- ldac? ( media-libs/libldac )
- >=net-wireless/bluez-5
- >=sys-apps/dbus-1.0.0
- ofono-headset? ( >=net-misc/ofono-1.13 )
- >=media-sound/pulseaudio-13[-bluetooth]
-"
-# Ordinarily media-libs/libldac should be in DEPEND too, but for now upstream repo is using a ldac submodule instead.
-
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-DISABLE_AUTOFORMATTING="no"
-DOC_CONTENTS="
-After getting media-sound/pulseaudio merged without its bluetooth
-support (to not collide with this) you may have removed the loading
-of bluetooth modules in default.pa config file, leading to failure
-to use your bluetooth device (see
-https://github.com/EHfive/pulseaudio-modules-bt/issues/33).
-Please ensure you have this lines present in your /etc/pulse/default.pa
-file:
-
-.ifexists module-bluetooth-policy.so
-load-module module-bluetooth-policy
-.endif
-
-.ifexists module-bluetooth-discover.so
-load-module module-bluetooth-discover
-.endif
-"
-
-src_configure() {
- local mycmakeargs=(
- -DCODEC_AAC_FDK=$(usex fdk "ON" "OFF")
- -DCODEC_APTX_FF=$(usex ffmpeg "ON" "OFF")
- -DCODEC_APTX_HD_FF=$(usex ffmpeg "ON" "OFF")
- -DCODEC_LDAC=$(usex ldac "ON" "OFF")
- -DNATIVE_HEADSET=$(usex native-headset "ON" "OFF")
- -DOFONO_HEADSET=$(usex ofono-headset "ON" "OFF")
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}