summaryrefslogtreecommitdiff
path: root/media-sound/pulseaudio-modules-bt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /media-sound/pulseaudio-modules-bt
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'media-sound/pulseaudio-modules-bt')
-rw-r--r--media-sound/pulseaudio-modules-bt/Manifest1
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4-r2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/media-sound/pulseaudio-modules-bt/Manifest b/media-sound/pulseaudio-modules-bt/Manifest
index 7c4dc561dcc9..95d7a9016717 100644
--- a/media-sound/pulseaudio-modules-bt/Manifest
+++ b/media-sound/pulseaudio-modules-bt/Manifest
@@ -2,5 +2,6 @@ DIST pulseaudio-13.0.tar.xz 1901768 BLAKE2B 651a80f54525f196bcb036d893fedd4d9f34
DIST pulseaudio-15.0.tar.xz 1521760 BLAKE2B a6f7b74fdcfe7f2a993eafb9f465946915a24b6801d3077971b9377290d6c70b3f8640a800abd09d5901db96a20349f31b1beedd9da2249f69b591fb8392f489 SHA512 352ef20384c76c631c0faa73b08e2318902a433712e0c086a5ac7a0ae58873c8d4be8f35879bdec71a93b19ae8e2ba073cacac4d56215bcf58375a0cd9d88833
DIST pulseaudio-modules-bt-1.4.tar.gz 87558 BLAKE2B 98b21d8fced5b88d59e45ca4fa2505d3606616a8a09dd95eb91e30b0d31c8a0ec7e52e4c2fd1b601130f69a997871064849fa0c8847ec0686fb42a2ccd7ac43b SHA512 390b6ad0931b464a546c6624bec38cc5b6da7084e4defe2045f4164b0c910a9dd6d4327466eb0e53fcfbc78c995cf2e3634a75b67ee2a14f38ed18e31b5d2bce
EBUILD pulseaudio-modules-bt-1.4-r1.ebuild 2170 BLAKE2B b692c89de2f16c30586737d6577531086f3cc6794f638de1dd7251711bfe9188c9d7ab341d9c8e73d3f4edbb517247d6ad6fd19e8996b576b2063d98b5170abf SHA512 7c28546f9eb9d1e4758d403d04eac9c76e7cac9c20c3b1e96891ba0be9cd6f77fbed171861d57315e967ed41b5f40171e99b6def9c5c24fb6df1c79d0216ac51
+EBUILD pulseaudio-modules-bt-1.4-r2.ebuild 2216 BLAKE2B cd82ba965af111a44f5c486ba4c333da1c1ccb84823bf1e92b296df3333dcb5e3b246c8bffcaf7f39419fe11a7035166da6f584c183b56143e52bfaa634a502d SHA512 fa5965f4a3c9f4a84b5d0af4ae3be2877fee1eb1f25c95d9654284cf147f9f842ab9681672e6b397d595730ee24dc2192eafa694b5ae418faf40d379b2084db2
EBUILD pulseaudio-modules-bt-1.4.ebuild 2170 BLAKE2B 9e09eaf4e2ba634bb05c48a8db1a813a201589c7dc41a44653de6d630e03571f5d73c6071ff03dc292218b47881eb9cab717ee71ee61ea1941777021e5d58e56 SHA512 af3d8e0303cd3eec86155cf390fdca9d0ea68000bd6c84f91a772be354a630fc20e06cf4c172ac9a702ec2bef5884f532c78cd2c9fb5c1243f3bc40c03628546
MISC metadata.xml 767 BLAKE2B 7787505018f779a109f761f1ad5d73bc19654491d1a9adb900fb97cb023abcb76753f964d9c39eb9a98924391bd8a08e916c652b21e942dda31c84e8e16dce01 SHA512 2b12af8d5dda44c9cb5f58685f49c65a865f29e9f1506f5d5e5c4cce6629b19e49774e71c7b078c877ed053ee5c6530d219cf9fbe1c2a8c9a4e4628c497d5848
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4-r2.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4-r2.ebuild
new file mode 100644
index 000000000000..5ce55a2c7a12
--- /dev/null
+++ b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth"
+HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
+
+PULSE_VER="15.0"
+SRC_URI="
+ https://github.com/EHfive/pulseaudio-modules-bt/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${PULSE_VER}.tar.xz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="fdk +ffmpeg +ldac +native-headset ofono-headset"
+
+DEPEND="
+ fdk? ( media-libs/fdk-aac:0= )
+ ffmpeg? ( media-video/ffmpeg )
+ media-libs/sbc
+ ldac? ( media-libs/libldac )
+ >=net-wireless/bluez-5
+ >=sys-apps/dbus-1.0.0
+ ofono-headset? ( >=net-misc/ofono-1.13 )
+ >=media-sound/pulseaudio-${PULSE_VER}[-bluetooth,daemon(+)]
+ !media-sound/pulseaudio[bluetooth]
+"
+# Ordinarily media-libs/libldac should be in DEPEND too, but for now upstream repo is using a ldac submodule instead.
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DISABLE_AUTOFORMATTING="no"
+DOC_CONTENTS="
+After getting media-sound/pulseaudio merged without its bluetooth
+support (to not collide with this) you may have removed the loading
+of bluetooth modules in default.pa config file, leading to failure
+to use your bluetooth device (see
+https://github.com/EHfive/pulseaudio-modules-bt/issues/33).
+Please ensure you have this lines present in your /etc/pulse/default.pa
+file:
+
+.ifexists module-bluetooth-policy.so
+load-module module-bluetooth-policy
+.endif
+
+.ifexists module-bluetooth-discover.so
+load-module module-bluetooth-discover
+.endif
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # pulseaudio headers needed to build
+ rmdir pa/ || die
+ ln -s ../pulseaudio-${PULSE_VER}/ pa || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCODEC_AAC_FDK=$(usex fdk "ON" "OFF")
+ -DCODEC_APTX_FF=$(usex ffmpeg "ON" "OFF")
+ -DCODEC_APTX_HD_FF=$(usex ffmpeg "ON" "OFF")
+ -DCODEC_LDAC=$(usex ldac "ON" "OFF")
+ -DNATIVE_HEADSET=$(usex native-headset "ON" "OFF")
+ -DOFONO_HEADSET=$(usex ofono-headset "ON" "OFF")
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}