summaryrefslogtreecommitdiff
path: root/media-sound/playerctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/playerctl
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/playerctl')
-rw-r--r--media-sound/playerctl/Manifest4
-rw-r--r--media-sound/playerctl/metadata.xml15
-rw-r--r--media-sound/playerctl/playerctl-0.5.0.ebuild51
3 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/playerctl/Manifest b/media-sound/playerctl/Manifest
new file mode 100644
index 000000000000..39a533688377
--- /dev/null
+++ b/media-sound/playerctl/Manifest
@@ -0,0 +1,4 @@
+DIST playerctl-0.5.0.tar.gz 17015 SHA256 e1ea761c05774471a0a1274ad93805178b32d55d358ece0424fd087c1def8017 SHA512 307cad5eeea7efa0c97c885660f49468f442fe907ef2495b56ac512e0551c7248750897b6d00934cbfcfcb35f486a101a238b276ef71d2ef866132ca3cc0932c WHIRLPOOL 11e374a1b38586a8ee362b821d503af8175c36f0b48f067c91176d32aeae034a4fbd6c1e2afc2c78987a7be574248f0c8f329efc2dcf4b07f8df52d8e7d35726
+EBUILD playerctl-0.5.0.ebuild 911 SHA256 55f668c757a5396f6efff67cdc9a11dd5033effb13185ae5d7f4fa1005f527c8 SHA512 0a8d421ab0874a479aca422f676c4b4ccc92cb1043ab82c799a332375439802da585d69afa3325a36f597e6ae6e25e8e8dab32631daf280ee8186ad5d116d8b1 WHIRLPOOL 25b27b61e311c4d87d3cb375336ae46f8a7668e540a991bb72bc233ec896f44dc47cfce838d36d4b6630c19b4bd02476bb6283a279fa54675a8e67751a6046cc
+MISC ChangeLog 831 SHA256 07065e126ff85048ba2609db976c921316eabdd13ba2efb595f653532a55658c SHA512 e5d32eeda9bfac0fb0c4f5a5fd5dc283080bff5185c6db2bd42d273e6eb40908c6e47516e5f3d5885cb4b21b61b20b1b060549c2ad89bab4f0e63b615a0e78db WHIRLPOOL 658477543f9b6acbd0f9b3778c5c9ce69565e895b480f92dcb68d632880b351b103b2b5db3d556df37dcd0bae22baf68e069014c3ee74bcef60c89d17050b451
+MISC metadata.xml 487 SHA256 e21947c51cd8faf1265f27d0c86dbe4b654d90c55d92d4e97775c188cc6573f4 SHA512 f97cd3597a70b86c784f11ffcc5c7c8fb5c16a124cb871907f8e3f216b7ff26d7e2954a52f52a5640fc8a8f41300a4419c527c57f410350a322ed36b1fa2e77f WHIRLPOOL 22eae4306d9eeb4f9fb0cd736196e257a015031395aa1da96eac64fa6f722056cc58f52b600fcac9bf2a2bd46c3e5123bfe4be02a00f6c4ce0cd68bd8c50bb54
diff --git a/media-sound/playerctl/metadata.xml b/media-sound/playerctl/metadata.xml
new file mode 100644
index 000000000000..42a351ac3998
--- /dev/null
+++ b/media-sound/playerctl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+ </maintainer>
+ <longdescription>
+ mpris command-line controller and library for spotify, vlc,
+ audacious, bmp, xmms2, and others.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">acrisci/playerctl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/playerctl/playerctl-0.5.0.ebuild b/media-sound/playerctl/playerctl-0.5.0.ebuild
new file mode 100644
index 000000000000..67ba0cbdc5cf
--- /dev/null
+++ b/media-sound/playerctl/playerctl-0.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools xdg-utils
+
+DESCRIPTION="A CLI utility to control media players over MPRIS"
+HOMEPAGE="https://github.com/acrisci/playerctl"
+SRC_URI="https://github.com/acrisci/playerctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ if ! use doc; then
+ echo 'EXTRA_DIST = ' > gtk-doc.make || die
+ fi
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ xdg_environment_reset # 596166
+
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc gtk-doc-html)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}