summaryrefslogtreecommitdiff
path: root/media-sound/picard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /media-sound/picard
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/Manifest1
-rw-r--r--media-sound/picard/picard-9999.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/picard/Manifest b/media-sound/picard/Manifest
index 85de666e1153..90673eae0f0c 100644
--- a/media-sound/picard/Manifest
+++ b/media-sound/picard/Manifest
@@ -1,3 +1,4 @@
DIST picard-1.4.2.tar.gz 2116021 BLAKE2B 9629d312df20a8c69b383b424724ef4cf9f774ae70b9e11b1c6c7f96cafea575657875642af70a73633ca79eb8c79237ada16dd5ff7c021d4bdb4a0df7890de3 SHA512 5e4a6a8cfadd86b7015ab77da1969acec26e0ed92564c6634afeee5060d33d34e8fc83015880e6c8f17df66c8d15b86a85031dbe5b596c995579fb449cf8a74e
EBUILD picard-1.4.2.ebuild 1580 BLAKE2B 6eb8fdc3564238a16750c5d3d4872430bfc57d8fdda0901549fc6d9ffb77451d888995abe3690c8fac65da465181bbbeadd1b2988680ee4b062cdef9611cb9b2 SHA512 4026302891e66e1bec8c76d99559f88a336454beab29a22c09e355d32378b0f7d648fb33c50a209ec5da6f696aef2195795e70ba4339f71a8e44cbbe0e80fc3f
+EBUILD picard-9999.ebuild 1633 BLAKE2B 8452d681019ae06f61be3257d120acc36b3d999d03e2f58b97a082deb9c55545d9768ae5b2a5376978d9a65b0355df4132c92242c4f75a7228ef71d8ee3428fa SHA512 4fe7b209a51dbb3a6940367cf5868174034cdb603c382f3efaf3ea6ce1f07f14840e3dc16e9ac4ec3b9c25373dd32d56cd4516387d3feb935dfa1cf2bce26cbd
MISC metadata.xml 564 BLAKE2B 0408874b350710d85cd50f27158d074ee0a22c392822bfd7d90ae455906934c6ec1fd5963f4f225d2852a7bcbb5f74ec756b8c5ae449d2159ef52d552f6da954 SHA512 ce79b6abdff9db80eeac888838dea351058b17e90ffc5b13d4b446203531948f80705ef4184b35623fef1a0952f0071d5b4588f2fee5d93cebbc902a1a97577d
diff --git a/media-sound/picard/picard-9999.ebuild b/media-sound/picard/picard-9999.ebuild
new file mode 100644
index 000000000000..a182c7b674a9
--- /dev/null
+++ b/media-sound/picard/picard-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+DISTUTILS_SINGLE_IMPL=1
+DISABLE_AUTOFORMATTING=true
+
+EGIT_REPO_URI="https://github.com/metabrainz/picard"
+inherit distutils-r1 git-r3 readme.gentoo-r1 xdg-utils
+
+DESCRIPTION="A cross-platform music tagger"
+HOMEPAGE="https://picard.musicbrainz.org"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls"
+
+RDEPEND="
+ dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtgui:5[accessibility]
+ >=media-libs/mutagen-1.38"
+DEPEND="
+ nls? ( dev-qt/linguist-tools:5 )
+"
+
+RESTRICT="test" # doesn't work with ebuilds
+
+python_compile() {
+ local build_args=(
+ --disable-autoupdate
+ )
+ if ! use nls; then
+ build_args+=( --disable-locales )
+ fi
+ distutils-r1_python_compile ${build_args[@]}
+}
+
+python_install() {
+ local install_args=(
+ --disable-autoupdate
+ --skip-build
+ )
+ if ! use nls; then
+ install_args+=( --disable-locales )
+ fi
+ distutils-r1_python_install ${install_args[@]}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
+calculation and lookup of AcoustID fingerprints.
+
+Install optional package dev-python/python-discid to enable
+calculation and lookup of compact disc identifiers (disc IDs).
+
+If you are upgrading Picard and it does not start, try removing
+Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}