summaryrefslogtreecommitdiff
path: root/media-sound/pasystray/pasystray-0.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-sound/pasystray/pasystray-0.8.0-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-sound/pasystray/pasystray-0.8.0-r1.ebuild')
-rw-r--r--media-sound/pasystray/pasystray-0.8.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/pasystray/pasystray-0.8.0-r1.ebuild b/media-sound/pasystray/pasystray-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..a58c48834bef
--- /dev/null
+++ b/media-sound/pasystray/pasystray-0.8.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="PulseAudio system tray"
+HOMEPAGE="https://github.com/christophgysin/pasystray"
+SRC_URI="https://github.com/christophgysin/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~x86"
+IUSE="libnotify zeroconf"
+
+RDEPEND="
+ dev-libs/glib
+ || ( media-sound/pulseaudio-daemon[glib,zeroconf?] <media-sound/pulseaudio-15.99.1[glib,zeroconf?] )
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ zeroconf? ( net-dns/avahi )
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notify) \
+ $(use_enable zeroconf avahi)
+}