summaryrefslogtreecommitdiff
path: root/media-sound/musescore/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /media-sound/musescore/files
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'media-sound/musescore/files')
-rw-r--r--media-sound/musescore/files/musescore-2.1.0-pch.patch31
-rw-r--r--media-sound/musescore/files/musescore-2.1.0-qt-5.11.patch21
-rw-r--r--media-sound/musescore/files/musescore-2.1.0-qtsingleapplication.patch28
3 files changed, 80 insertions, 0 deletions
diff --git a/media-sound/musescore/files/musescore-2.1.0-pch.patch b/media-sound/musescore/files/musescore-2.1.0-pch.patch
new file mode 100644
index 000000000000..d69d1cd2f654
--- /dev/null
+++ b/media-sound/musescore/files/musescore-2.1.0-pch.patch
@@ -0,0 +1,31 @@
+From 5e8024c683891be677075d74cedfbf424e36bc31 Mon Sep 17 00:00:00 2001
+From: mirabilos <tg@debian.org>
+Date: Sun, 4 Mar 2018 16:38:21 +0100
+Subject: [PATCH] Fix numerous reports of missing all.h during compilation
+
+When disabling PCH, the all.h copying code is no longer run before
+AUTOMOC=caused *_autogen targets, so we must run it earlier.
+
+From Debian
+---
+ CMakeLists.txt | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 66b0ddfce8..7fdfffcc9b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -553,11 +553,8 @@ endif (NOT MINGW AND NOT APPLE)
+ #
+
+ # all.h is expected in PROJECT_BINARY_DIR by subdirs
+-add_custom_command(
+- OUTPUT ${PROJECT_BINARY_DIR}/all.h
+- COMMAND ${CMAKE_COMMAND}
+- ARGS -E copy ${PROJECT_SOURCE_DIR}/all.h ${PROJECT_BINARY_DIR}/all.h
+- DEPENDS ${PROJECT_SOURCE_DIR}/all.h
++execute_process(
++ COMMAND ${CMAKE_COMMAND} -E copy ${PROJECT_SOURCE_DIR}/all.h ${PROJECT_BINARY_DIR}/all.h
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ )
+ \ No newline at end of file
diff --git a/media-sound/musescore/files/musescore-2.1.0-qt-5.11.patch b/media-sound/musescore/files/musescore-2.1.0-qt-5.11.patch
new file mode 100644
index 000000000000..2fa6afd9395d
--- /dev/null
+++ b/media-sound/musescore/files/musescore-2.1.0-qt-5.11.patch
@@ -0,0 +1,21 @@
+From 9c8a8ffe0cbb00ee93a10fe245da01a4d32ca086 Mon Sep 17 00:00:00 2001
+From: Orcan Ogetbil <orcan@localhost.localdomain>
+Date: Thu, 31 May 2018 21:04:51 -0400
+Subject: [PATCH] added missing #include <QButtonGroup> required by qt >= 5.11
+
+---
+ all.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/all.h b/all.h
+index 72db72b0ec..2ee0e8e807 100644
+--- a/all.h
++++ b/all.h
+@@ -131,6 +131,7 @@
+ #include <QProgressBar>
+ #include <QProgressDialog>
+ #include <QRadioButton>
++#include <QButtonGroup>
+ #include <QSplashScreen>
+ #include <QFontComboBox>
+ #include <QApplication>
diff --git a/media-sound/musescore/files/musescore-2.1.0-qtsingleapplication.patch b/media-sound/musescore/files/musescore-2.1.0-qtsingleapplication.patch
new file mode 100644
index 000000000000..1e362dd3298a
--- /dev/null
+++ b/media-sound/musescore/files/musescore-2.1.0-qtsingleapplication.patch
@@ -0,0 +1,28 @@
+From 4c28258db05dd6d33bbcd037a05a7fbbb66f67ab Mon Sep 17 00:00:00 2001
+From: Joachim Schmitz <jojo@schmitz-digital.de>
+Date: Wed, 8 Aug 2018 09:16:54 +0200
+Subject: [PATCH] Fix #52106: fails to compile with
+ -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON
+
+---
+ CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3a30c03d63..be6a50578a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -537,8 +537,13 @@ endif(APPLE)
+ ##
+
+ if (USE_SYSTEM_QTSINGLEAPPLICATION)
++ if (USE_PATH_WITH_EXPLICIT_QT_VERSION)
++ find_path(QTSINGLEAPPLICATION_INCLUDE_DIRS qtsingleapplication.h PATH_SUFFIXES qt5/QtSolutions)
++ find_library(QTSINGLEAPPLICATION_LIBRARIES Qt5Solutions_SingleApplication-2.6)
++ else (USE_PATH_WITH_EXPLICIT_QT_VERSION)
+ find_path(QTSINGLEAPPLICATION_INCLUDE_DIRS qtsingleapplication.h PATH_SUFFIXES QtSolutions)
+ find_library(QTSINGLEAPPLICATION_LIBRARIES QtSolutions_SingleApplication-2.6)
++ endif (USE_PATH_WITH_EXPLICIT_QT_VERSION)
+ else(USE_SYSTEM_QTSINGLEAPPLICATION)
+ subdirs (thirdparty/singleapp)
+ set(QTSINGLEAPPLICATION_INCLUDE_DIRS ${PROJECT_SOURCE_DIR}/singleapp/src)