summaryrefslogtreecommitdiff
path: root/media-sound/mpg321/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/mpg321/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/mpg321/files')
-rw-r--r--media-sound/mpg321/files/mpg321-0.2.12-check-for-lround.patch16
-rw-r--r--media-sound/mpg321/files/mpg321-0.3.2-format-security.patch38
2 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/mpg321/files/mpg321-0.2.12-check-for-lround.patch b/media-sound/mpg321/files/mpg321-0.2.12-check-for-lround.patch
new file mode 100644
index 000000000000..ca52f7241167
--- /dev/null
+++ b/media-sound/mpg321/files/mpg321-0.2.12-check-for-lround.patch
@@ -0,0 +1,16 @@
+diff -ur mpg321-0.2.12-1.orig//configure.ac mpg321-0.2.12-1/configure.ac
+--- mpg321-0.2.12-1.orig//configure.ac 2010-07-03 07:46:40.000000000 -0400
++++ mpg321-0.2.12-1/configure.ac 2011-08-20 19:50:32.143229893 -0400
+@@ -75,6 +75,12 @@
+
+ AC_CHECK_FUNCS([gethostbyname memset munmap socket strchr strdup strerror strrchr strstr gettimeofday select getenv putenv setenv unsetenv strcasecmp])
+
++dnl Check if math library is needed.
++AC_CHECK_FUNC(lround)
++if test "$ac_cv_func_lround" = no; then
++ AC_CHECK_LIB(m, lround)
++fi
++
+ AC_ARG_ENABLE(mpg123_symlink,
+ [ --enable-mpg123-symlink Enable symlink of mpg123 to mpg321 [[default=yes]] ],
+ ,enable_mpg123_symlink=yes)
diff --git a/media-sound/mpg321/files/mpg321-0.3.2-format-security.patch b/media-sound/mpg321/files/mpg321-0.3.2-format-security.patch
new file mode 100644
index 000000000000..732ca2c60225
--- /dev/null
+++ b/media-sound/mpg321/files/mpg321-0.3.2-format-security.patch
@@ -0,0 +1,38 @@
+--- /var/tmp/portage/media-sound/mpg321-0.3.2/work/mpg321-0.3.2-orig/mpg321.c 2012-03-25 14:27:49.000000000 +0200
++++ /tmp/mpg321.c 2015-08-12 23:34:20.395331151 +0200
+@@ -183,7 +183,7 @@
+ else{
+ #endif
+ if(!(options.opt & MPG321_ENABLE_BUFFER))
+- fprintf(stderr,"Volume: %ld%% \r",volume);
++ fprintf(stderr,"Volume: %d%% \r",volume);
+ #ifdef HAVE_ALSA
+ }
+ #endif
+@@ -233,7 +233,7 @@
+ else{
+ #endif
+ if(!(options.opt & MPG321_ENABLE_BUFFER))
+- fprintf(stderr,"Volume: %ld%% \r",volume);
++ fprintf(stderr,"Volume: %d%% \r",volume);
+ #ifdef HAVE_ALSA
+ }
+ #endif
+@@ -447,7 +447,7 @@
+ {
+ if(!names[i])
+ {
+- printf(emptystring);
++ printf("%s", emptystring);
+ }
+
+ else
+@@ -465,7 +465,7 @@
+ for (i=0; i<=5; i++) {
+ fprintf (stderr, "%s", info_id3[i].name);
+ if (!names[i]) {
+- fprintf (stderr, emptystring);
++ fprintf (stderr, "%s", emptystring);
+ } else {
+ fprintf (stderr, "%s", names[i]);
+ free (names[i]);