summaryrefslogtreecommitdiff
path: root/media-sound/mpdas/mpdas-0.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/mpdas/mpdas-0.4.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/mpdas/mpdas-0.4.2.ebuild')
-rw-r--r--media-sound/mpdas/mpdas-0.4.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/mpdas/mpdas-0.4.2.ebuild b/media-sound/mpdas/mpdas-0.4.2.ebuild
new file mode 100644
index 000000000000..65382e379dd7
--- /dev/null
+++ b/media-sound/mpdas/mpdas-0.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="An AudioScrobbler client for MPD written in C++"
+HOMEPAGE="http://50hz.ws/mpdas/"
+SRC_URI="http://50hz.ws/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libmpdclient
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/@//' Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CXX
+ emake CONFIG="/etc"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+ dodoc mpdasrc.example README
+}
+
+pkg_postinst() {
+ elog "For further configuration help consult the README in"
+ elog "${EPREFIX}/usr/share/doc/${PF}"
+}