summaryrefslogtreecommitdiff
path: root/media-sound/mp3val/mp3val-0.1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/mp3val/mp3val-0.1.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/mp3val/mp3val-0.1.8.ebuild')
-rw-r--r--media-sound/mp3val/mp3val-0.1.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/mp3val/mp3val-0.1.8.ebuild b/media-sound/mp3val/mp3val-0.1.8.ebuild
new file mode 100644
index 000000000000..ed2f5fc906a3
--- /dev/null
+++ b/media-sound/mp3val/mp3val-0.1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Validate and fix MPEG audio files"
+HOMEPAGE="http://mp3val.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mp3val/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+PATCHES=(
+ "${FILESDIR}/${P}-open.patch"
+)
+
+src_prepare() {
+ edos2unix "${S}"/{*.{cpp,h},Makefile*}
+ chmod a-x "${S}"/*
+ sed -i -e '/^C.*FLAGS.*=/d' "${S}"/Makefile.linux
+ default
+}
+
+src_compile() {
+ emake -f Makefile.linux
+}
+
+src_install() {
+ dobin mp3val
+ dohtml manual.html
+ dodoc changelog.txt
+}