summaryrefslogtreecommitdiff
path: root/media-sound/mp3check/mp3check-0.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
commitd56d144655e3785864da43c9acb6c228ef9360ae (patch)
treeb769b599a558483f82e9a057c41f1edd29626dd1 /media-sound/mp3check/mp3check-0.8.7.ebuild
parentfab849d1daed0ba7f2ac497d07985c3dbb692543 (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'media-sound/mp3check/mp3check-0.8.7.ebuild')
-rw-r--r--media-sound/mp3check/mp3check-0.8.7.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/media-sound/mp3check/mp3check-0.8.7.ebuild b/media-sound/mp3check/mp3check-0.8.7.ebuild
index ee78058978c7..97e7d314e0c2 100644
--- a/media-sound/mp3check/mp3check-0.8.7.ebuild
+++ b/media-sound/mp3check/mp3check-0.8.7.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings"
@@ -11,20 +12,18 @@ SRC_URI="https://${PN}.googlecode.com/files/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-src_prepare() {
- sed -i -e '/^WARN/s:-g::' Makefile || die
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.7-fix-buildsystem.patch
+ "${FILESDIR}"/${PN}-0.8.7-fix-c++14-operator-delete.patch
+)
src_configure() {
# tfiletools.h:59:50: warning: dereferencing type-punned pointer will break
# strict-aliasing rules [-Wstrict-aliasing]
append-cxxflags -fno-strict-aliasing
-}
-src_compile() {
- emake CXX="$(tc-getCXX)" OPT="${CXXFLAGS}"
+ tc-export CXX
}
src_install() {