summaryrefslogtreecommitdiff
path: root/media-sound/mp3check/mp3check-0.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/mp3check/mp3check-0.8.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/mp3check/mp3check-0.8.7.ebuild')
-rw-r--r--media-sound/mp3check/mp3check-0.8.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/mp3check/mp3check-0.8.7.ebuild b/media-sound/mp3check/mp3check-0.8.7.ebuild
new file mode 100644
index 000000000000..ee78058978c7
--- /dev/null
+++ b/media-sound/mp3check/mp3check-0.8.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings"
+HOMEPAGE="https://code.google.com/p/mp3check/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e '/^WARN/s:-g::' Makefile || die
+}
+
+src_configure() {
+ # tfiletools.h:59:50: warning: dereferencing type-punned pointer will break
+ # strict-aliasing rules [-Wstrict-aliasing]
+ append-cxxflags -fno-strict-aliasing
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" OPT="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman *.1
+}