summaryrefslogtreecommitdiff
path: root/media-sound/moosic/moosic-1.5.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/moosic/moosic-1.5.6-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/moosic/moosic-1.5.6-r1.ebuild')
-rw-r--r--media-sound/moosic/moosic-1.5.6-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/moosic/moosic-1.5.6-r1.ebuild b/media-sound/moosic/moosic-1.5.6-r1.ebuild
new file mode 100644
index 000000000000..854d843be91c
--- /dev/null
+++ b/media-sound/moosic/moosic-1.5.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Music player that focuses on easy playlist management"
+HOMEPAGE="http://www.nanoo.org/~daniel/moosic"
+SRC_URI="http://www.nanoo.org/~daniel/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e 's:distutils.core:setuptools:' setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/*.html )
+
+ distutils-r1_python_install_all
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ newbashcomp examples/completion ${PN}
+ dodoc doc/{Moosic_API.txt,moosic_hackers.txt,Todo}
+ dodoc examples/server_config
+}