summaryrefslogtreecommitdiff
path: root/media-sound/linuxsampler/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/linuxsampler/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/linuxsampler/files')
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-2.0.0-lv2-automagic.patch21
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-2.0.0-nptl-hardened.patch15
2 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/linuxsampler/files/linuxsampler-2.0.0-lv2-automagic.patch b/media-sound/linuxsampler/files/linuxsampler-2.0.0-lv2-automagic.patch
new file mode 100644
index 000000000000..a5b9f8d71efa
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-2.0.0-lv2-automagic.patch
@@ -0,0 +1,21 @@
+--- linuxsampler-2.0.0/configure.ac
++++ linuxsampler-2.0.0/configure.ac
+@@ -532,12 +532,12 @@
+ AM_CONDITIONAL(HAVE_DSSI, test $config_have_dssi = "yes")
+
+ # LV2
+-PKG_CHECK_MODULES(LV2, lv2 >= 1.0.0, config_have_lv2="yes", config_have_lv2="no")
+-if test "$config_have_lv2" != "yes"; then
+- PKG_CHECK_MODULES(LV2, lv2core >= 1.0.0, config_have_lv2="yes", config_have_lv2="no")
+-fi
+-AC_SUBST(LV2_CFLAGS)
+-AC_SUBST(LV2_LIBS)
++AC_ARG_ENABLE([lv2],
++ AS_HELP_STRING([--enable-lv2], [Enable building with lv2]))
++config_have_lv2="no"
++AS_IF([test "x$enable_lv2" = "xyes"], [
++ PKG_CHECK_MODULES([LV2], [lv2 >= 1.0.0 lv2core >= 1.0.0], [config_have_lv2="yes"])
++])
+ AM_CONDITIONAL(HAVE_LV2, test $config_have_lv2 = "yes")
+
+ # VST
diff --git a/media-sound/linuxsampler/files/linuxsampler-2.0.0-nptl-hardened.patch b/media-sound/linuxsampler/files/linuxsampler-2.0.0-nptl-hardened.patch
new file mode 100644
index 000000000000..0c61f096c213
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-2.0.0-nptl-hardened.patch
@@ -0,0 +1,15 @@
+Fix breakage caused by undefined behaviour. Using PTHREAD_CANCEL_ASYNCHRONOUS
+is only allowed in pure functions.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=537516
+
+--- linuxsampler-2.0.0/m4/nptl_bug.m4
++++ linuxsampler-2.0.0/m4/nptl_bug.m4
+@@ -47,7 +47,7 @@
+ void* __pthread_launcher(void* p) {
+ // let the thread be killable under any circumstances
+ // (without this function call, this test always succeeds !)
+- pthread_setcanceltype(PTHREAD_CANCEL_ASYNCHRONOUS, NULL);
++ pthread_setcanceltype(PTHREAD_CANCEL_DEFERRED, NULL);
+
+ // this will block this 2nd thread, since we already
+ // locked this mutex by the main thread