summaryrefslogtreecommitdiff
path: root/media-sound/liblc3/liblc3-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-26 19:33:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-26 19:33:08 +0100
commite52012895af4c92f008daac78c3d8b6d691a5dd1 (patch)
tree23cfaf6724a2a4437945e792ce42481a83acfd4a /media-sound/liblc3/liblc3-1.0.3.ebuild
parente41409e9c4ccf0cd1b45b81f9d2370d13326cfc2 (diff)
gentoo auto-resync : 26:06:2023 - 19:33:07
Diffstat (limited to 'media-sound/liblc3/liblc3-1.0.3.ebuild')
-rw-r--r--media-sound/liblc3/liblc3-1.0.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-sound/liblc3/liblc3-1.0.3.ebuild b/media-sound/liblc3/liblc3-1.0.3.ebuild
new file mode 100644
index 000000000000..2dd84db02299
--- /dev/null
+++ b/media-sound/liblc3/liblc3-1.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="LC3 is an efficient low latency audio codec"
+HOMEPAGE="https://github.com/google/liblc3"
+SRC_URI="https://github.com/google/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="tools"
+KEYWORDS="~amd64"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use tools)
+ )
+ meson_src_configure
+}