summaryrefslogtreecommitdiff
path: root/media-sound/krecorder/krecorder-23.08.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
commit31c69c39a3648b52dd931a40b198714249e8a5ec (patch)
treec7bfb4db01cf185b6b8f7bde72d9cc5d14d8db22 /media-sound/krecorder/krecorder-23.08.5.ebuild
parentdce60e5aa0a12ccc07c10a0a2c3f8f063393b32a (diff)
gentoo auto-resync : 15:02:2024 - 23:36:26
Diffstat (limited to 'media-sound/krecorder/krecorder-23.08.5.ebuild')
-rw-r--r--media-sound/krecorder/krecorder-23.08.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/krecorder/krecorder-23.08.5.ebuild b/media-sound/krecorder/krecorder-23.08.5.ebuild
new file mode 100644
index 000000000000..2fd14b12d7ee
--- /dev/null
+++ b/media-sound/krecorder/krecorder-23.08.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="utilities"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Convergent audio recording application for Plasma"
+HOMEPAGE="https://apps.kde.org/krecorder/"
+
+LICENSE="CC0-1.0 CC-BY-4.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/kirigami-addons-0.6:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5[qml]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+"
+BDEPEND=">=kde-frameworks/ki18n-${KFMIN}:5"