summaryrefslogtreecommitdiff
path: root/media-sound/guayadeque/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /media-sound/guayadeque/files
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'media-sound/guayadeque/files')
-rw-r--r--media-sound/guayadeque/files/guayadeque-0.4.6-gcc10.patch70
-rw-r--r--media-sound/guayadeque/files/guayadeque-0.4.6-metadata.patch13
2 files changed, 83 insertions, 0 deletions
diff --git a/media-sound/guayadeque/files/guayadeque-0.4.6-gcc10.patch b/media-sound/guayadeque/files/guayadeque-0.4.6-gcc10.patch
new file mode 100644
index 000000000000..41529d20c051
--- /dev/null
+++ b/media-sound/guayadeque/files/guayadeque-0.4.6-gcc10.patch
@@ -0,0 +1,70 @@
+From 6be35ba2153f1c36400b8c535d8ba49292a1f51e Mon Sep 17 00:00:00 2001
+From: Juan Rios <anonbeat@gmail.com>
+Date: Wed, 20 May 2020 05:23:22 +0100
+Subject: [PATCH] Fix compilation with gcc and fix some warnings with wxString
+ Trim
+
+---
+ src/ui/jamendo/Jamendo.cpp | 5 ++---
+ src/ui/mediaviewer/playlists/PlayListFile.cpp | 4 ++--
+ src/ui/podcasts/PodcastsPanel.cpp | 2 +-
+ 3 files changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/src/ui/jamendo/Jamendo.cpp b/src/ui/jamendo/Jamendo.cpp
+index 8725bb60..107cadd7 100644
+--- a/src/ui/jamendo/Jamendo.cpp
++++ b/src/ui/jamendo/Jamendo.cpp
+@@ -487,7 +487,7 @@ guJamendoUpdateThread::~guJamendoUpdateThread()
+ }
+ }
+
+-#if 0
++/*
+ <JamendoData epoch="1282819258" documentation="http://developer.jamendo.com/en/wiki/DatabaseDumps" type="artistalbumtrack">
+ <Artists>
+ <artist>
+@@ -538,8 +538,7 @@ guJamendoUpdateThread::~guJamendoUpdateThread()
+ </artist>
+ ...
+ </Artists>
+-#endif
+-
++*/
+
+ // -------------------------------------------------------------------------------- //
+ void ReadJamendoXmlTrack( wxXmlNode * xmlnode, guJamendoUpdateThread * thread, guTrack * track )
+diff --git a/src/ui/mediaviewer/playlists/PlayListFile.cpp b/src/ui/mediaviewer/playlists/PlayListFile.cpp
+index a7ae4a4d..e038e20b 100644
+--- a/src/ui/mediaviewer/playlists/PlayListFile.cpp
++++ b/src/ui/mediaviewer/playlists/PlayListFile.cpp
+@@ -287,7 +287,7 @@ bool guPlaylistFile::ReadM3uStream( wxInputStream &playlist, const wxString &pat
+ int Count = Lines.Count();
+ for( Index = 0; Index < Count; Index++ )
+ {
+- Lines[ Index ].Trim( wxString::both );
++ Lines[ Index ].Trim( false ).Trim( true );
+ if( Lines[ Index ].IsEmpty() || ( Lines[ Index ].Find( wxT( "#EXTM3U" ) ) != wxNOT_FOUND ) )
+ {
+ continue;
+@@ -676,7 +676,7 @@ bool guCuePlaylistFile::LoadFromText( const wxString &content )
+ int Count = Lines.Count();
+ for( Index = 0; Index < Count; Index++ )
+ {
+- Lines[ Index ].Trim( wxString::both );
++ Lines[ Index ].Trim( false ).Trim( true );
+ wxString Line = Lines[ Index ];
+ //guLogMessage( wxT( "'%s'" ), Line.c_str() );
+ wxArrayString Keys = wxStringTokenize( Line, wxT( " " ) );
+diff --git a/src/ui/podcasts/PodcastsPanel.cpp b/src/ui/podcasts/PodcastsPanel.cpp
+index b715bd29..f242608d 100644
+--- a/src/ui/podcasts/PodcastsPanel.cpp
++++ b/src/ui/podcasts/PodcastsPanel.cpp
+@@ -1193,7 +1193,7 @@ void guPodcastPanel::AddChannel( wxCommandEvent &event )
+ wxSetCursor( * wxHOURGLASS_CURSOR );
+ wxTheApp->Yield();
+
+- wxString PodcastUrl = NewPodcastChannel->GetValue().Trim( wxString::both );
++ wxString PodcastUrl = NewPodcastChannel->GetValue().Trim( false ).Trim( true );
+ if( !PodcastUrl.IsEmpty() )
+ {
+ // If we find an itunes link we replace the itpc to the standard http
diff --git a/media-sound/guayadeque/files/guayadeque-0.4.6-metadata.patch b/media-sound/guayadeque/files/guayadeque-0.4.6-metadata.patch
new file mode 100644
index 000000000000..b35be4f133fa
--- /dev/null
+++ b/media-sound/guayadeque/files/guayadeque-0.4.6-metadata.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e46d921..40e640e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -158,7 +158,7 @@ ADD_SUBDIRECTORY( po )
+ # freedesktop.org-specific files
+ INSTALL( FILES defconfig/guayadeque.desktop DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/applications )
+ INSTALL( FILES defconfig/guayadeque.png DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/pixmaps )
+-INSTALL( FILES defconfig/guayadeque.appdata.xml DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/appdata )
++INSTALL( FILES defconfig/guayadeque.appdata.xml DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/metadata )
+
+ # program-specific files
+ INSTALL( FILES defconfig/guayadeque.default.conf DESTINATION ${CMAKE_INSTALL_DATADIR}/guayadeque )