summaryrefslogtreecommitdiff
path: root/media-sound/gstreamripper/gstreamripper-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/gstreamripper/gstreamripper-0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/gstreamripper/gstreamripper-0.2.ebuild')
-rw-r--r--media-sound/gstreamripper/gstreamripper-0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/gstreamripper/gstreamripper-0.2.ebuild b/media-sound/gstreamripper/gstreamripper-0.2.ebuild
new file mode 100644
index 000000000000..c418b4dad9ef
--- /dev/null
+++ b/media-sound/gstreamripper/gstreamripper-0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+MY_P=GStreamripperX-${PV}
+
+DESCRIPTION="A GTK+ toolkit based frontend for streamripper"
+HOMEPAGE="https://sourceforge.net/projects/gstreamripper/"
+SRC_URI="mirror://sourceforge/gstreamripper/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+COMMON_DEPEND="x11-libs/gtk+:2"
+RDEPEND="${COMMON_DEPEND}
+ media-sound/streamripper"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ local docdir=/usr/share/doc/${PF}
+
+ emake \
+ DESTDIR="${D}" \
+ gstreamripperxdocdir=${docdir} \
+ install || die
+
+ rm -f "${D}"/${docdir}/{COPYING,NEWS,TODO}
+
+ make_desktop_entry gstreamripperx GStreamripperX
+}