summaryrefslogtreecommitdiff
path: root/media-sound/grip/grip-4.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
commit82020bf7ff936f52f6f1efc646ae374e46b5ed36 (patch)
tree1b1d0c4ea3c8e8d77a6066d8ac29c51cececd1a9 /media-sound/grip/grip-4.2.4.ebuild
parent0bdb5244708888dfc364e30b08facc0a45281f78 (diff)
gentoo auto-resync : 29:11:2022 - 13:20:25
Diffstat (limited to 'media-sound/grip/grip-4.2.4.ebuild')
-rw-r--r--media-sound/grip/grip-4.2.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/grip/grip-4.2.4.ebuild b/media-sound/grip/grip-4.2.4.ebuild
new file mode 100644
index 000000000000..09c22db206c4
--- /dev/null
+++ b/media-sound/grip/grip-4.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic toolchain-funcs xdg strip-linguas
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ !app-text/grip
+ dev-libs/glib:2
+ media-libs/id3lib
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}