summaryrefslogtreecommitdiff
path: root/media-sound/gramofile/gramofile-1.6_p9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/gramofile/gramofile-1.6_p9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/gramofile/gramofile-1.6_p9.ebuild')
-rw-r--r--media-sound/gramofile/gramofile-1.6_p9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/gramofile/gramofile-1.6_p9.ebuild b/media-sound/gramofile/gramofile-1.6_p9.ebuild
new file mode 100644
index 000000000000..1ed1c4b6e0f8
--- /dev/null
+++ b/media-sound/gramofile/gramofile-1.6_p9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Transfer sound from gramophone records to CD"
+HOMEPAGE="http://www.opensourcepartners.nl/~costar/gramofile"
+SRC_URI="
+ mirror://debian/pool/main/g/${PN}/${PN}_${PV/_p*}.orig.tar.gz
+ mirror://debian/pool/main/g/${PN}/${PN}_${PV/_p*}-${PV/*_p}.diff.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ sys-libs/ncurses
+ sci-libs/fftw:2.1
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${PV/_p*}-${PV/*_p}.diff
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch ${P/_p*}/debian/patches
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-strlen_and_exit.patch
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ dobin ${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bplay_gramo brec_gramo
+ dodoc ChangeLog README TODO *.txt
+ newdoc ${P/_p*}/debian/changelog ChangeLog.debian
+}