summaryrefslogtreecommitdiff
path: root/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild')
-rw-r--r--media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild41
1 files changed, 14 insertions, 27 deletions
diff --git a/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild b/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild
index 3d144fcc11c7..e3ecb295b17b 100644
--- a/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild
+++ b/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils gnome2-utils xdg-utils
+inherit eutils gnome2-utils xdg
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/squentin/${PN}.git"
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
KEYWORDS=""
else
- GIT_COMMIT="853840eb9dad0b59ad2dac5d303f5929b2f09f21"
+ GIT_COMMIT="4538a5af5fb6c11f07bd7a9c50d6fd73b18c840d"
SRC_URI="https://github.com/squentin/${PN}/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-${GIT_COMMIT}"
@@ -24,23 +24,20 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="dbus doc extras gstreamer libnotify mplayer"
-GSTREAMER_DEPEND="dev-perl/Glib-Object-Introspection"
-MPLAYER_DEPEND="media-video/mplayer"
-MPV_DEPEND="media-video/mpv"
-OTHER_DEPEND="
- media-sound/alsa-utils
- media-sound/flac123
- || ( media-sound/mpg123 media-sound/mpg321 )
- media-sound/vorbis-tools"
-
RDEPEND="dev-lang/perl
dev-perl/Gtk2
virtual/perl-MIME-Base64
|| ( net-misc/wget dev-perl/AnyEvent-HTTP )
dbus? ( dev-perl/Net-DBus )
- gstreamer? ( ${GSTREAMER_DEPEND} )
- mplayer? ( || ( ${MPLAYER_DEPEND} ${MPV_DEPEND} ) )
- !gstreamer? ( !mplayer? ( ${OTHER_DEPEND} ) )
+ gstreamer? ( dev-perl/Glib-Object-Introspection )
+ mplayer? ( || ( media-video/mplayer media-video/mpv ) )
+ !gstreamer? ( !mplayer? (
+ media-sound/alsa-utils
+ media-sound/flac123
+ || ( media-sound/mpg123 media-sound/mpg321 )
+ media-sound/vorbis-tools
+ )
+ )
extras? ( dev-perl/gnome2-wnck )
libnotify? ( dev-perl/Gtk2-Notify )"
DEPEND="sys-devel/gettext
@@ -53,19 +50,9 @@ src_compile() {
src_install() {
emake \
DESTDIR="${D}" \
- iconsdir="${D%/}/usr/share/icons/hicolor" \
+ iconsdir="${D}/usr/share/icons/hicolor" \
install
use doc && local HTML_DOCS=( layout_doc.html )
einstalldocs
}
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}