summaryrefslogtreecommitdiff
path: root/media-sound/gmtp/gmtp-1.3.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/gmtp/gmtp-1.3.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/gmtp/gmtp-1.3.10.ebuild')
-rw-r--r--media-sound/gmtp/gmtp-1.3.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/gmtp/gmtp-1.3.10.ebuild b/media-sound/gmtp/gmtp-1.3.10.ebuild
new file mode 100644
index 000000000000..9f56fbc962a1
--- /dev/null
+++ b/media-sound/gmtp/gmtp-1.3.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit gnome2-utils
+
+DESCRIPTION="A simple MTP client for MP3 players"
+HOMEPAGE="http://gmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ media-libs/flac
+ media-libs/libid3tag
+ media-libs/libmtp
+ media-libs/libvorbis
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-gtk3
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}