summaryrefslogtreecommitdiff
path: root/media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild')
-rw-r--r--media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild40
1 files changed, 24 insertions, 16 deletions
diff --git a/media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild b/media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
index 0b9ae98c4bb2..7d875e3d3fd6 100644
--- a/media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
+++ b/media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="a graphical music player daemon (MPD) client using GTK+2"
HOMEPAGE="https://launchpad.net/gimmix"
@@ -13,25 +14,32 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="cover lyrics taglib"
-RDEPEND=">=media-libs/libmpd-0.17
- gnome-base/libglade
+RDEPEND="
+ media-libs/libmpd:=
+ gnome-base/libglade:=
x11-libs/gtk+:2
- cover? ( net-libs/libnxml net-misc/curl )
- lyrics? ( net-libs/libnxml net-misc/curl )
- taglib? ( >=media-libs/taglib-1.5 )"
-DEPEND="${RDEPEND}
+ cover? (
+ net-libs/libnxml:=
+ net-misc/curl:=
+ )
+ lyrics? (
+ net-libs/libnxml:=
+ net-misc/curl:=
+ )
+ taglib? ( media-libs/taglib:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
dev-util/intltool"
-DOCS=( AUTHORS ChangeLog README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.7.1-curl-headers.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${PN}-0.5.7.2-QA-desktop-file.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.5.7.1-curl-headers.patch \
- "${FILESDIR}"/${P}-format-security.patch
- sed -i -e "/^Icon/s/\.png$//" \
- -e "/^Categories/s/Application;//" data/gimmix.desktop
-
- # broken build system in tarball
+ default
eautoreconf
}