summaryrefslogtreecommitdiff
path: root/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 09:53:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 09:53:01 +0100
commitf7436a5ce1c11f1c33cd09dd757f768cd07b19fd (patch)
tree6296aa82e3fe61664c80ba6cdd0d7cc410a1c2ad /media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
parent80422eacf48ea819f1aeefc7a809533aa63fb85a (diff)
gentoo auto-resync : 29:03:2023 - 09:53:01
Diffstat (limited to 'media-sound/frescobaldi/frescobaldi-3.3.0.ebuild')
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild b/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
new file mode 100644
index 000000000000..7db5046cd3b0
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 xdg
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="https://www.frescobaldi.org/"
+SRC_URI="https://github.com/frescobaldi/frescobaldi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/python-ly[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/qpageview[${PYTHON_USEDEP}]
+ media-sound/lilypond"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+ emake -C i18n
+ emake -C linux
+}