summaryrefslogtreecommitdiff
path: root/media-sound/freebirth/freebirth-0.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/freebirth/freebirth-0.3.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/freebirth/freebirth-0.3.2-r1.ebuild')
-rw-r--r--media-sound/freebirth/freebirth-0.3.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/freebirth/freebirth-0.3.2-r1.ebuild b/media-sound/freebirth/freebirth-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..271853ab4567
--- /dev/null
+++ b/media-sound/freebirth/freebirth-0.3.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Free software bass synthesizer step sequencer"
+HOMEPAGE="http://freshmeat.net/releases/8834"
+SRC_URI="http://www.bitmechanic.com/projects/freebirth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo-2.patch \
+ "${FILESDIR}"/${P}-segfault.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/${PN}/raw
+ doins raw/*.raw
+
+ dodoc CHANGES NEXT_VERSION README
+
+ doicon xpm/${PN}.xpm
+ make_desktop_entry ${PN} ${PN}
+}