summaryrefslogtreecommitdiff
path: root/media-sound/fluidsynth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 18:51:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 18:51:10 +0000
commitaa44121f587698ace480d5ca16ae9e64fe1b4d0b (patch)
tree51e169f07cbed2c1aca51f5e6ae3152233d68f27 /media-sound/fluidsynth
parent7d58bf45ea7b2d8f188fd2aa40484a8c9a3381a7 (diff)
gentoo auto-resync : 14:11:2022 - 18:51:10
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest4
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.3.0.ebuild121
-rw-r--r--media-sound/fluidsynth/metadata.xml1
3 files changed, 125 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 5cb3439bbdd5..15e9f77139cb 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,5 @@
DIST fluidsynth-2.2.9.tar.gz 1750977 BLAKE2B a6b4a19737d01e86a80084cdf88897da9af7d2c50be80fb0227a1d70effb8551667ae27f43ce63591830acfdef31ff0d99d51e3160b9b09c274637b259a82833 SHA512 90f44f6d7a4ed504eea5e2d39d8da2e0072bef746f3d969e367f0bab36a4cff479a98e795dc8b6b58b565fb266c44a137a14e98c7e4c77d1be3b300b8c066600
+DIST fluidsynth-2.3.0.tar.gz 1757143 BLAKE2B 845f4b1d00b743edf7ef8a5660c239c2924ca51306fbd8f45c0c965198ed2d5267bacf8333a44720beb3f283e9a75bbb8b497dcb0b004153d5f8a9d9ed4f5224 SHA512 621a54f7d9845a9350381e9aa99f342b28050e1dd80983e69828acc685ace39ee5376f8e40d7a93ddb247718e4bcfb3f196cbd4027343251f8c0fbe3c0d219ed
EBUILD fluidsynth-2.2.9.ebuild 3392 BLAKE2B 1fa6acdd1ea5d223df74ba0c3b1106676ee9bb0c518a2eed129ecd4c6b49ff8d691cc67702dba1663869daefab6687a12eb776069f45f44b953dd129f9c46df2 SHA512 b5369a6033e7dd4bdb73f93c794ebe47824fd425ad08c97d10fc2352d4d74bbc98bc6300ca85eff72f255d248735bc7579f4311950a48f7d195af1b6ad1df3bd
-MISC metadata.xml 431 BLAKE2B f739f538274e2e63b1977673b0766a594db59982ab71d6552d1e841434c4040bb7af29d441b1d9e8ce61385dbdb8e522b5591f6826a4c52f085bf004f9fe8426 SHA512 c8085e7652a504610fb841e302ee380de58a67a16a9b874447c00ee20c2d56119254eed954704e8bd4cf8e574980da2dd2f90baa5c99e59cd534e26245af67bb
+EBUILD fluidsynth-2.3.0.ebuild 3452 BLAKE2B 56758951eee5749e3518bcd3b7624324fe9aa42fce4ba35a2813f0a1c7940c6fc18d99791275819cd99a68fb4105883b4f099b86943258dc8d7d860636e251ec SHA512 d7c7732631cdb5a2f9cdd1a1305b646564383873742c2c547aa36c8ed57f4a9b9930b49985754878f0a74dd5699f0b601a83b5353dde449755882415dd3db34f
+MISC metadata.xml 486 BLAKE2B 9df033e417835f43720a3e90329da4144ed3932a185a228622331cd490d00e5057e85192c32fd7cd303c182d830182cc543f48a3669223d69890159af179c5d4 SHA512 3ca4231c97c3a7ea49d0398a201db7b7ab1589e4dfab940872907c9d10c2115cdb66c52431aa7d1076824b4bf96ecc87908d2a09df1391d241cf8f6df1f5dc65
diff --git a/media-sound/fluidsynth/fluidsynth-2.3.0.ebuild b/media-sound/fluidsynth/fluidsynth-2.3.0.ebuild
new file mode 100644
index 000000000000..d5a21ab76f24
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-2.3.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib systemd toolchain-funcs
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="https://www.fluidsynth.org"
+SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
+ media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
+ )
+ pipewire? (
+ media-video/pipewire:0=[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_C_COMPILER="$(tc-getCC)"
+ -Denable-alsa=$(usex alsa)
+ -Denable-aufile=ON
+ -Denable-dbus=$(usex dbus)
+ -Denable-dsound=OFF # Windows
+ -Denable-floats=OFF # loat instead of double for DSP samples
+ -Denable-fpe-check=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-libinstpatch=ON # https://github.com/swami/libinstpatch
+ -Denable-midishare=OFF # http://midishare.sourceforge.net/
+ -Denable-network=$(usex network)
+ -Denable-opensles=OFF
+ -Denable-oboe=OFF # requires OpenSLES and/or AAudio
+ -Denable-oss=$(usex oss)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-profiling=$(usex debug)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-pipewire=$(usex pipewire)
+ -Denable-readline=$(usex readline)
+ -Denable-sdl2=$(usex sdl)
+ -Denable-systemd=$(usex systemd)
+ -Denable-threads=$(usex threads)
+ -Denable-trap-on-fpe=$(usex debug)
+ -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
+ -Denable-waveout=OFF # Windows
+ -Denable-winmidi=OFF # Windows
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ if use systemd; then
+ mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+install_systemd_files() {
+ if multilib_is_native_abi; then
+ systemd_dounit "${BUILD_DIR}/fluidsynth.service"
+ insinto /etc
+ doins "${BUILD_DIR}/fluidsynth.conf"
+ fi
+}
+
+multilib_src_test() {
+ eninja check
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+
+ if use systemd; then
+ multilib_foreach_abi install_systemd_files
+
+ elog "When using fluidsynth as a systemd service, make sure"
+ elog "to configure your fluidsynth settings globally in "
+ elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
+ fi
+}
diff --git a/media-sound/fluidsynth/metadata.xml b/media-sound/fluidsynth/metadata.xml
index 5f9feb05c374..940387fae30c 100644
--- a/media-sound/fluidsynth/metadata.xml
+++ b/media-sound/fluidsynth/metadata.xml
@@ -10,5 +10,6 @@
</upstream>
<use>
<flag name="network">enable network support (requires BSD sockets)</flag>
+ <flag name="pipewire">enable pipewire support</flag>
</use>
</pkgmetadata>