summaryrefslogtreecommitdiff
path: root/media-sound/fluidsynth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-21 19:03:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-21 19:03:35 +0000
commit0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (patch)
tree15bb76d57cfb8652fd2627a24007e0bb92ec4a99 /media-sound/fluidsynth
parent5b5df25227111ef465caf5c52bcfb66dac3219cd (diff)
gentoo resync : 21.01.2018
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest4
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.9.ebuild70
-rw-r--r--media-sound/fluidsynth/metadata.xml2
3 files changed, 74 insertions, 2 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index ebb1286fdd91..4704eae823b1 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,5 @@
DIST fluidsynth-1.1.6.tar.gz 958735 BLAKE2B 9be1e72238545d78f2aded9e98336639ba83d2272b3247ac86609e84331fb8517eb29b505d269719196468bdbf645496c9f4f4426ac232b16f19b3b8b1c3450f SHA512 2dcb8a8a1634273cc93c45b6e21b87ac45a023c768cffdadda0a4e611eab8d5bbea0e1ba59e5f147488054cfa6fcaf561399ae275a665c76082b8738a80778bb
+DIST fluidsynth-1.1.9.tar.gz 630651 BLAKE2B 2e6faa1126778a98b1960146046490331f943dfe78dcbf66aeaac16deda3ea0bca2eca747e7041ba752d136360b2003ae89b0d936df78a6cd9d5024bd3cd834e SHA512 9bbe9143dc55a0e10e33efd62698e28b598a7ede95d44f193a93c5e29920c7b6d08f7f5ba96bd2c1c42a4b184134d4e811f643fdc0077be714c0cf72635de235
EBUILD fluidsynth-1.1.6-r1.ebuild 2161 BLAKE2B 86ab6aac8b65c858cfb4a72ba4c153040c9303f2ed8e655983b47472f1a6d7d4b8c6a66a2c0da25006bb1a4de6199897e53266d414ae7518e1b762fb47ac366b SHA512 9949a64762e561bcb6e77e38fef18c8882898a20a0bdcfa6b95478e1a251bf22a54818ef5b63b8fea8e1a714fe435a48c7af8b701917e60dd60a9de37108c38c
-MISC metadata.xml 333 BLAKE2B a8c08969065a90e37dfec55b3cb9eab3140c64360acb810fd4fc5850e27c2a27744314aab5a0d09b50e72224c08aca1e1885869ae639eaa586ebac0c5e4c1868 SHA512 016dcb0abac11ce0dedc95e5a8998b3c82f3c31c17a7d9c34baa095854c1cab7b2c0a77e091a754ed653705245473800f7356fb1f6ae7653b53582e42ca7a58d
+EBUILD fluidsynth-1.1.9.ebuild 2253 BLAKE2B 47c026d1d29245f63395a93e81e719da1f88b8b7fc483954702e5b2a8bcbe30fe2fa2ff5c700d37c65a7c862c53e6d529984b6224443edbc2662fb6f152cba1b SHA512 272838ed901704d279f38e12c6a5fdbdd2b46db2184dbe6d528b95f65648af2ed97caa6af565e7a370e0064bac0ba7dc4e89705d0980cf1238fcff53e1e19717
+MISC metadata.xml 339 BLAKE2B 4bc7678ba8ccc3e97a79dda9294b31ffc1950212619ace448def22e50852b20e3b716368d9c5b7127aff381aab85d7fa104404fcd409144452855a4b5d41b529 SHA512 abac43fa8ab39fe41adf6c34a4f0e3aa605dbe834555b2eac4abcaadb6556cc08555197aadc43e51733cf8d4e30c7f7be3efb724536d54604069055836a36980
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.9.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.9.ebuild
new file mode 100644
index 000000000000..18d329d31b20
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="https://github.com/FluidSynth/fluidsynth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}]
+ lash? ( >=media-sound/lash-0.5.4-r2[${MULTILIB_USEDEP}] ) )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}]
+ >=media-libs/ladspa-cmt-1.16-r3[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ portaudio? ( >=media-libs/portaudio-19_pre20111121-r1[${MULTILIB_USEDEP}] )
+ readline? ( >=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}] )
+ sndfile? ( >=media-libs/libsndfile-1.0.25[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+src_configure() {
+ # autotools based build system has AC_CHECK_LIB(pthread, pthread_create) wrt
+ # bug #436762
+ append-flags -pthread
+
+ mycmakeargs=(
+ $(cmake-utils_use alsa enable-alsa)
+ $(cmake-utils_use dbus enable-dbus)
+ $(cmake-utils_use debug enable-debug)
+ $(cmake-utils_use ipv6 enable-ipv6)
+ $(cmake-utils_use jack enable-jack)
+ -Denable-ladcca=OFF
+ $(cmake-utils_use ladspa enable-ladspa)
+ $(cmake-utils_use sndfile enable-libsndfile)
+ $(cmake-utils_use portaudio enable-portaudio)
+ $(cmake-utils_use pulseaudio enable-pulseaudio)
+ $(cmake-utils_use readline enable-readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( $(cmake-utils_use lash enable-lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ dodoc AUTHORS NEWS README.md THANKS TODO doc/*.txt
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/*.c
+ fi
+}
diff --git a/media-sound/fluidsynth/metadata.xml b/media-sound/fluidsynth/metadata.xml
index 439f7cda7dde..81333c2546c1 100644
--- a/media-sound/fluidsynth/metadata.xml
+++ b/media-sound/fluidsynth/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Sound project</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">fluidsynth</remote-id>
+ <remote-id type="github">FluidSynth/fluidsynth</remote-id>
</upstream>
</pkgmetadata>