summaryrefslogtreecommitdiff
path: root/media-sound/flacon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /media-sound/flacon
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'media-sound/flacon')
-rw-r--r--media-sound/flacon/Manifest2
-rw-r--r--media-sound/flacon/flacon-4.1.0.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/media-sound/flacon/Manifest b/media-sound/flacon/Manifest
index 5ca000b771a9..21c7e033611e 100644
--- a/media-sound/flacon/Manifest
+++ b/media-sound/flacon/Manifest
@@ -1,3 +1,5 @@
DIST flacon-4.0.0.tar.gz 1294289 BLAKE2B 3afadc3545493558a5eadb7720509410fb448fed1e1fc5511f0ce477ea0e6e876d19e3038d5eb77191b449f730f50e6f1e3e4eacf546b064868863ed918acdee SHA512 64efc3369f11a7345d106a253873bcaf64ff0bbfb045e3554fecdc48a86ee5d150bef06643a5bf481d6e139a45a2bfdee91e730f9aa1354a4772f0d994297b78
+DIST flacon-4.1.0.tar.gz 1579869 BLAKE2B 6e0bf31f0eb47bf594d74e0f058f333daa9ee84f9313e75e059f1568386c20f79482926f6f786d332ecfbb72c3991e346a7b98ab8f27a2a4b4ce5c195c23d6bb SHA512 4e786571ba3e157aad2dc27523f8b9de259b44b84c7b054124a610199ef19855832000e4499d18bd6f725f2133bbbbf8d0d75f1cafbdce918605c3b407f6b0ef
EBUILD flacon-4.0.0.ebuild 2472 BLAKE2B 7f289cf3b0cd94d757bc47122d117af72be6d8e9bb8ab273af64bbffd955f01e59b63effb27e821bb1ab6f119cc504700acb4efaed33e202ad5c02a362352c77 SHA512 a6300f02429e8eca6a81dbae41cd6904f76c3114f182765f60dd8e2851cf83132f3e0d497dc3c8ee5f0079df54b028811fbc71e028064c980c5bc0c72f96c4a8
+EBUILD flacon-4.1.0.ebuild 2489 BLAKE2B e2758ce755d64e56c6e6be78d7afae63ef1e67de9bca2da495308207c24088b4c42cb630692004db75e6de866c42b1132968a1f2e2e3ebf63d80aa4282780eca SHA512 18daf05b3bea3f0fd977a93f70ed8882e94dd9718fc43bb2e2dd0e6010d756bf2d9ad239d87e5522855d1b463685972291b973a59ade1d44a78f26506d68509d
MISC metadata.xml 505 BLAKE2B 95e22c79d22d438696eaca5a304e1ac5660b049511a59bf6ed79aeedf9039b24fcd4de3ee3babc4c34b9e471a615ffcc1a36a9156350e430dc6fa6ca6bbd9923 SHA512 6979e575ee4e5230e7674fa77ece86fc27b983af03c1dfd938c3b3ca9e8f0e89f7ab2c99eaecdd1f512e70fd9d1004963669bfefa68176d40c6460272ac334dc
diff --git a/media-sound/flacon/flacon-4.1.0.ebuild b/media-sound/flacon/flacon-4.1.0.ebuild
new file mode 100644
index 000000000000..65405aff3fb8
--- /dev/null
+++ b/media-sound/flacon/flacon-4.1.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Ignore rudimentary et, uz@Latn, zh_TW translation(s).
+PLOCALES="cs cs_CZ de el es es_MX fr gl hu it ja_JP lt ms_MY nb nl nl_BE pl pl_PL pt_BR pt_PT ro_RO ru sr sr@latin tr uk zh_CN"
+# Tests require lots of disk space
+CHECKREQS_DISK_BUILD=10G
+
+inherit check-reqs cmake-utils eutils gnome2-utils l10n virtualx xdg-utils
+
+DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
+HOMEPAGE="https://flacon.github.io/"
+SRC_URI="https://github.com/flacon/flacon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ app-i18n/uchardet
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ test? (
+ dev-qt/qttest:5
+ media-libs/flac
+ media-sound/mac
+ media-sound/shntool
+ media-sound/ttaenc
+ media-sound/wavpack
+ )
+"
+
+pkg_pretend() {
+ use test && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use test && check-reqs_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Ignore rudimentary et, uz@Latn, zh_TW translation(s).
+ rm "translations/${PN}_uz@Latn.desktop" || die
+ rm "translations/${PN}"_{et,zh_TW}.ts || die
+
+ remove_locale() {
+ rm "translations/${PN}_${1}".{ts,desktop} || die
+ }
+
+ l10n_find_plocales_changes 'translations' "${PN}_" '.ts'
+ l10n_for_each_disabled_locale_do remove_locale
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ virtx "${BUILD_DIR}/tests/${PN}_test"
+}
+
+pkg_postinst() {
+ elog "${PN} optionally supports formats listed below."
+ elog "(List will be empty if all extra packages are installed.)"
+ elog "Please install the required packages and restart ${PN}."
+ optfeature 'FLAC input and output support' media-libs/flac
+ optfeature 'WavPack input and output support' media-sound/wavpack
+ optfeature 'APE input support' media-sound/mac
+ optfeature 'TTA input support' media-sound/ttaenc
+ optfeature 'AAC output support' media-libs/faac
+ optfeature 'MP3 output support' media-sound/lame
+ optfeature 'Vorbis output support' media-sound/vorbis-tools
+ optfeature 'MP3 Replay Gain support' media-sound/mp3gain
+ optfeature 'Vorbis Replay Gain support' media-sound/vorbisgain
+
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}