summaryrefslogtreecommitdiff
path: root/media-sound/dvda-author
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /media-sound/dvda-author
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'media-sound/dvda-author')
-rw-r--r--media-sound/dvda-author/Manifest4
-rw-r--r--media-sound/dvda-author/dvda-author-10.06-r1.ebuild34
-rw-r--r--media-sound/dvda-author/files/dvda-author-10.06-desktop-QA.patch11
-rw-r--r--media-sound/dvda-author/files/dvda-author-10.06-fno-common.patch22
4 files changed, 57 insertions, 14 deletions
diff --git a/media-sound/dvda-author/Manifest b/media-sound/dvda-author/Manifest
index aabcf89db97d..1f0e03485ee7 100644
--- a/media-sound/dvda-author/Manifest
+++ b/media-sound/dvda-author/Manifest
@@ -1,3 +1,5 @@
+AUX dvda-author-10.06-desktop-QA.patch 301 BLAKE2B 5ea771cf5da1b5ad4faedcf7aa4a101cadedfc8789383839214f080d8281bf810c90485c313f6cf532ddd2677ab295a17e30bd270df9074cdb0506f31eb35a57 SHA512 e603dc660918350ccf3bdec2e1833459a2042d2a901e620c43ec0ad3750689f39c99c5b6f12105e8364995156b5b47969f4814550a54949a63d3320b2435bcfb
+AUX dvda-author-10.06-fno-common.patch 618 BLAKE2B e07e84500c6725ed7c7f2d9ff5d1733645b0dc4b0b7d46bb14c7b7c63053031ac2c2f39f36c543c2005117220c24b603039a79d227a5d4db9f0ae8119d10c4ac SHA512 556f8c3256e14233a6030b31e01c0d1d2304fe9884e9ed9d235fda7d3cf015d1cc51c0ee276fdbc05f4d27f393b0ba4aaffce29c8ea3a0f5f32c1cb56968198f
DIST dvda-author-10.06-300.tar.gz 828028 BLAKE2B bb1000024a4879989980246443c2ac7a7f795140b7c6165422793829c927c16fa8603c3a44a2f08e6e677e21871bffca6a5c330878688bcffa1b0fa2862290f0 SHA512 619215e5e9ac4a3e55d2bef0222a931412946f129927f1042807ee25541d64609a5a9189c843fdc30d34bb0e41e0779d821d8c32a16cf89c6227d9925ea07024
-EBUILD dvda-author-10.06-r1.ebuild 1272 BLAKE2B 1218f54db522eea1d3201d3193be825a191cce16fff72cee21db3be77a2fadca0c776872af57477e71cee26303eeffeb3e1dfa780c093c8e334238fe84acb02f SHA512 386b340c4bc8b999ea78d0e084ea9b70cb45126959ea58a2616a7de5db64c081a569ab6af6408455e9d2db1c5f3535e4ed6cf661eaafc46dfe8eb2f818f72890
+EBUILD dvda-author-10.06-r1.ebuild 1292 BLAKE2B fcf8f5caea44c858874cf63a20b7e5727c17602cc5aa99159af5e921691dc2ab0cc6dc7061dfdf452448a402646b5639125993ed35a6f105c5959b7877cd69ff SHA512 23ded05b1854991d3ee7ecfe013960b5e0693fca626e675c4b02a2283532047796dfecab53998de2afd5259d25137edbe54594707813462f2662133c4a632e1f
MISC metadata.xml 332 BLAKE2B 1501e697062fd49d3cdce60850f04ffbb77f94c547751b9f8f3075cd598cc0dfb291638d8f5f1c356911f78fa3a285eff8cd2acc326fe16cee821682f150bab2 SHA512 85c9b13baabe446a5c74613084fb53f83071219d872dccef40b946c2f36c4df4f0cbc1e964779fe9c989d8081c483d82c10ad454e5d225b00361a851b5e0400c
diff --git a/media-sound/dvda-author/dvda-author-10.06-r1.ebuild b/media-sound/dvda-author/dvda-author-10.06-r1.ebuild
index 965f73db2aae..811fbf5d248c 100644
--- a/media-sound/dvda-author/dvda-author-10.06-r1.ebuild
+++ b/media-sound/dvda-author/dvda-author-10.06-r1.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
+
+inherit desktop toolchain-funcs
DESCRIPTION="Author a DVD-Audio DVD"
HOMEPAGE="http://dvd-audio.sourceforge.net"
@@ -12,12 +14,20 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-RDEPEND=">=media-sound/sox-14.1[png]
- >=media-libs/flac-1.2.1[ogg]"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2"
+RDEPEND="
+ media-sound/sox[png]
+ media-libs/flac[ogg]"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/libtool"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-desktop-QA.patch
+)
src_prepare() {
+ default
+
# Fix parallel make
sed -i -e 's:^\(\tcd ${MAYBE_CDRTOOLS}\):@HAVE_CDRTOOLS_BUILD_TRUE@\1:' \
Makefile.in || die "sed failed"
@@ -33,19 +43,17 @@ src_prepare() {
src_configure() {
econf \
- --with-config=/etc \
+ --with-config="${EPREFIX}/etc" \
$(use_with debug debug full)
}
src_compile() {
- # make[1]: warning: jobserver unavailable: using -j1.
- # Add '+' to parent make rule.
- emake -j1
+ emake AR="$(tc-getAR)" all
}
src_install() {
- newbin src/dvda ${PN}
- insinto /etc
- doins ${PN}.conf
- dodoc AUTHORS BUGS ChangeLog EXAMPLES HOWTO.conf LIMITATIONS NEWS TODO
+ default
+
+ domenu "${ED}"/etc/dvda-author.desktop
+ rm -r "${ED}"/etc/{menu,dvda-author.desktop} || die
}
diff --git a/media-sound/dvda-author/files/dvda-author-10.06-desktop-QA.patch b/media-sound/dvda-author/files/dvda-author-10.06-desktop-QA.patch
new file mode 100644
index 000000000000..adb2d1c53b0b
--- /dev/null
+++ b/media-sound/dvda-author/files/dvda-author-10.06-desktop-QA.patch
@@ -0,0 +1,11 @@
+--- a/dvda-author.desktop.in
++++ b/dvda-author.desktop.in
+@@ -7,7 +7,5 @@
+ Icon=@prefix@/share/pixmaps/dvda-author.png
+ Terminal=false
+ Type=Application
+-Categories=Application;AudioVideo;Audio
+-GenericName[en_EN]=Terminal Program
++Categories=AudioVideo;Audio
+ StartupNotify=true
+-GenericName[fr_FR]=
diff --git a/media-sound/dvda-author/files/dvda-author-10.06-fno-common.patch b/media-sound/dvda-author/files/dvda-author-10.06-fno-common.patch
new file mode 100644
index 000000000000..2f549f02ddbb
--- /dev/null
+++ b/media-sound/dvda-author/files/dvda-author-10.06-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/src/command_line_parsing.c
++++ b/src/command_line_parsing.c
+@@ -33,7 +33,7 @@
+ /* #define _GNU_SOURCE must appear before <string.h> and <getopt.h> for strndup and getopt_long*/
+
+
+-globalData globals;
++extern globalData globals;
+ unsigned int startsector;
+ extern char* OUTDIR, *LOGFILE, *WORKDIR, *TEMPDIR;
+ static fileinfo_t ** files;
+--- a/src/menu.c
++++ b/src/menu.c
+@@ -30,7 +30,7 @@ extern globalData globals;
+
+ uint16_t norm_x=PAL_X, norm_y=PAL_Y; // TODO: adjust for ntsc #define NTSC_Y 480
+ extern uint16_t totntracks;
+-uint8_t maxbuttons, resbuttons;
++extern uint8_t maxbuttons, resbuttons;
+
+
+