summaryrefslogtreecommitdiff
path: root/media-sound/dcd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /media-sound/dcd/files
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'media-sound/dcd/files')
-rw-r--r--media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch20
-rw-r--r--media-sound/dcd/files/dcd-0.95-makefile.patch6
2 files changed, 22 insertions, 4 deletions
diff --git a/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch b/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..d3160424fc20
--- /dev/null
+++ b/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch
@@ -0,0 +1,20 @@
+--- a/dcd.c
++++ b/dcd.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <getopt.h>
++#include <time.h>
+
+ #define ZERO 0
+ #define MAX_TRACKS 103
+--- a/screenop.c
++++ b/screenop.c
+@@ -10,6 +10,7 @@
+ #include "cdindex.h"
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+
+ void disk_directory(void) {
+ u_char ct = cd_current_track();
diff --git a/media-sound/dcd/files/dcd-0.95-makefile.patch b/media-sound/dcd/files/dcd-0.95-makefile.patch
index b59fedb6180c..c5ea478beb1d 100644
--- a/media-sound/dcd/files/dcd-0.95-makefile.patch
+++ b/media-sound/dcd/files/dcd-0.95-makefile.patch
@@ -1,7 +1,5 @@
-Index: dcd-0.95/Makefile
-===================================================================
---- dcd-0.95.orig/Makefile
-+++ dcd-0.95/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -114,7 +114,7 @@ all: ${PROGS}
$(CC) -c $(CFLAGS) ${EXTRA_CFLAGS} $< -o $@