summaryrefslogtreecommitdiff
path: root/media-sound/csound/csound-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-sound/csound/csound-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-sound/csound/csound-9999.ebuild')
-rw-r--r--media-sound/csound/csound-9999.ebuild93
1 files changed, 49 insertions, 44 deletions
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index b0de613cfe23..f29357886e45 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -1,17 +1,21 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# As upstream (and we aswell) are not allowed to redistribute scansyn,
+# we have to repackage the tarball. For that purpose use `bash files/repackage.sh version`
+# Reference: https://github.com/csound/csound/issues/1148
+
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils java-pkg-opt-2 python-single-r1 toolchain-funcs
+inherit cmake python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
inherit git-r3
else
DOC_P="Csound${PV}"
- SRC_URI="https://github.com/csound/csound/archive/${PV}.tar.gz -> ${P}.tar.gz
+ SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/${P}-distributable.tar.xz
doc? (
https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_pdf.zip
https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_html.zip
@@ -27,12 +31,10 @@ SLOT="0"
# java doesn't work atm as it needs to have some variables specified to work, see src_configure
# mp3 doesnt work as media-sound/lame does not install cmake file
IUSE="+alsa beats chua curl +cxx debug doc double-precision dssi examples
-fltk +fluidsynth +image jack keyboard linear lua luajit nls osc portaudio
+fltk +fluidsynth hdf5 +image jack keyboard linear lua luajit nls osc portaudio
portaudio portmidi pulseaudio python samples static-libs stk test +threads +utils
vim-syntax websocket"
-IUSE_LANGS=" de en_US es es_CO fr it ro ru"
-
REQUIRED_USE="
linear? ( double-precision )
lua? ( cxx )
@@ -41,7 +43,6 @@ REQUIRED_USE="
# java? ( cxx )
BDEPEND="
- dev-libs/boost:=
sys-devel/flex
virtual/yacc
chua? ( dev-libs/boost )
@@ -70,6 +71,7 @@ CDEPEND="
)
fluidsynth? ( media-sound/fluidsynth:= )
fltk? ( x11-libs/fltk:1[threads?] )
+ hdf5? ( sci-libs/hdf5 )
image? ( media-libs/libpng:0= )
jack? ( virtual/jack )
keyboard? ( x11-libs/fltk:1[threads?] )
@@ -85,10 +87,13 @@ CDEPEND="
python? ( ${PYTHON_DEPS} )
stk? ( media-libs/stk )
utils? ( !media-sound/snd )
- websocket? ( net-libs/libwebsockets )
+ websocket? ( net-libs/libwebsockets:= )
"
RDEPEND="${CDEPEND}"
-DEPEND="${CDEPEND}"
+DEPEND="
+ ${CDEPEND}
+ dev-libs/boost
+"
if [[ ${PV} != "9999" ]]; then
DEPEND+="doc? ( app-arch/unzip )"
@@ -97,6 +102,10 @@ fi
# requires specific alsa settings
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/${PN}-6.13.0-xdg-open.patch"
+)
+
pkg_setup() {
if use python || use test ; then
python-single-r1_pkg_setup
@@ -104,36 +113,28 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
-e '/-O3/d' \
-i CMakeLists.txt || die
-
- local lang
-
- for lang in ${IUSE_LANGS} ; do
- if ! has ${lang} ${LINGUAS-${lang}} ; then
- sed -i "/compile_po(${lang}/d" po/CMakeLists.txt || die
- fi
- done
}
src_configure() {
local mycmakeargs=(
- #-DBUILD_BELA=OFF
- #-DBUILD_BUCHLA_OPCODES=ON
+ -DBUILD_BELA=OFF
+ -DBUILD_BUCHLA_OPCODES=ON
-DBUILD_CHUA_OPCODES=$(usex chua)
-DBUILD_CSBEATS=$(usex beats)
- #-DBUILD_CUDA_OPCODES=OFF
+ -DBUILD_CUDA_OPCODES=OFF
-DBUILD_CXX_INTERFACE=$(usex cxx)
-DBUILD_DSSI_OPCODES=$(usex dssi)
- #-DBUILD_EMUGENS_OPCODES=ON
- #-DBUILD_EXCITER_OPCODES=ON
+ -DBUILD_EMUGENS_OPCODES=ON
+ -DBUILD_EXCITER_OPCODES=ON
-DBUILD_FAUST_OPCODES=OFF
-DBUILD_FLUID_OPCODES=$(usex fluidsynth)
- #-DBUILD_FRAMEBUFFER_OPCODES=ON
- #-DBUILD_HDF5_OPCODES=ON
+ -DBUILD_FRAMEBUFFER_OPCODES=ON
+ -DBUILD_HDF5_OPCODES=$(usex hdf5)
-DBUILD_IMAGE_OPCODES=$(usex image)
-DBUILD_JACK_OPCODES=$(usex jack)
-DBUILD_JAVA_INTERFACE=OFF
@@ -141,27 +142,26 @@ src_configure() {
-DBUILD_LUA_INTERFACE=$(usex lua)
-DBUILD_MP3OUT_OPCODE=OFF
-DBUILD_MULTI_CORE=$(usex threads)
- #-DBUULD_OPENCL_OPCODES=OFF
+ -DBUILD_OPENCL_OPCODES=OFF
-DBUILD_OSC_OPCODES=$(usex osc)
-DBUILD_P5GLOVE_OPCODES=OFF
- #-DBUILD_PADSYNTH_OPCODES=ON
- #-DBUILD_PLATEREV_OPCODES=ON
- #-DBUILD_PVSGENDY_OPCODE=OFF
+ -DBUILD_PADSYNTH_OPCODES=ON
+ -DBUILD_PLATEREV_OPCODES=ON
+ -DBUILD_PVSGENDY_OPCODE=OFF
-DBUILD_PYTHON_INTERFACE=$(usex python)
-DBUILD_PYTHON_OPCODES=$(usex python)
-DBUILD_RELEASE=ON
- #-DBUILD_SCANSYN_OPCODES=ON
- #-DBUILD_SELECT_OPCODE=ON
- #-DBUILD_SERIAL_OPCODES=ON
- -DBUILD_SHARED_LIBS=ON
- #-DBUILD_STACK_OPCODES=ON
+ -DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
+ -DBUILD_SELECT_OPCODE=ON
+ -DBUILD_SERIAL_OPCODES=ON
+ -DBUILD_STACK_OPCODES=ON
-DBUILD_STATIC_LIBRARY=$(usex static-libs)
-DBUILD_STATIC_LIBRARY=$(usex test)
-DBUILD_STK_OPCODES=$(usex stk)
-DBUILD_TESTS=$(usex test)
-DBUILD_UTILITIES=$(usex utils)
-DBUILD_VIRTUAL_KEYBOARD=$(usex keyboard)
- #-DBUILD_VST4CS_OPCODES=OFF
+ -DBUILD_VST4CS_OPCODES=OFF
-DBUILD_WEBSOCKET_OPCODE=$(usex websocket)
-DBUILD_WIIMOTE_OPCODES=OFF
-DBUILD_WINSOUND=OFF
@@ -172,16 +172,16 @@ src_configure() {
-DUSE_ALSA=$(usex alsa)
#-DUSE_ATOMIC_BUILTIN=ON
- #-DUSE_AUDIOUNIT=ON
+ -DUSE_AUDIOUNIT=OFF # Apple specific
#-DUSE_COMPILER_OPTIMIZATIONS=ON
- #-DUSE_COREMIDI=ON
+ -DUSE_COREMIDI=OFF # Apple specific
-DUSE_CURL=$(usex curl)
-DUSE_DOUBLE=$(usex double-precision)
-DUSE_FLTK=$(usex fltk)
-DUSE_GETTEXT=$(usex nls)
-DUSE_GIT_COMMIT=ON
- #_DUSE_IPMIDI=ON
- #-DUSE_LRINT=ON
+ _DUSE_IPMIDI=ON
+ -DUSE_LRINT=ON
-DUSE_JACK=$(usex jack)
-DUSE_PORTAUDIO=$(usex portaudio)
-DUSE_PORTMIDI=$(usex portmidi)
@@ -199,16 +199,20 @@ src_configure() {
# set the library that we want to use
if use lua ; then
- local package
+ local libdir
+ local libname
if use luajit ; then
- package="luajit"
+ libdir=$(pkg-config --variable=libdir luajit)
+ libname=$(pkg-config --variable=libname luajit)
else
- package="lua"
+ libdir=$(pkg-config --variable=libdir lua)
+ libname=$(pkg-config --variable=libname lua)
+ [[ -z "${libname}" ]] && libname="lua"
fi
mycmakeargs+=(
- -DLUA_LIBRARY="$(pkg-config --variable=libdir ${package})/lib$(pkg-config --variable=libname ${package}).so"
+ -DLUA_LIBRARY="${libdir}/lib${libname}.so"
)
fi
@@ -216,15 +220,16 @@ src_configure() {
-DPYTHON_MODULE_INSTALL_DIR="$(python_get_sitedir)"
)
+ # this is needed, otherwise it sets LIBRARY INSTALL DIR: lib
[[ $(get_libdir) == "lib64" ]] && mycmakeargs+=(
-DUSE_LIB64=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc -r Release_Notes/.
# generate env.d file