summaryrefslogtreecommitdiff
path: root/media-sound/cadence/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/cadence/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/cadence/files')
-rw-r--r--media-sound/cadence/files/cadence-0.9.1-fix-qt5.15.patch34
-rw-r--r--media-sound/cadence/files/cadence-add-skip-stripping.patch65
2 files changed, 34 insertions, 65 deletions
diff --git a/media-sound/cadence/files/cadence-0.9.1-fix-qt5.15.patch b/media-sound/cadence/files/cadence-0.9.1-fix-qt5.15.patch
new file mode 100644
index 000000000000..b9c52167e375
--- /dev/null
+++ b/media-sound/cadence/files/cadence-0.9.1-fix-qt5.15.patch
@@ -0,0 +1,34 @@
+From c167f35fbb76c4246c730b29262a59da73010412 Mon Sep 17 00:00:00 2001
+From: Alex Tsitsimpis <alex.tsitsimpis@gmail.com>
+Date: Thu, 4 Jun 2020 12:49:40 +0300
+Subject: [PATCH] Fix build with Qt 5.15+
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Building with Qt 5.15 failed with the following error:
+
+../widgets/pixmapdial.cpp:231:26: error: aggregate ‘QPainterPath ballPath’ has incomplete type and cannot be defined
+ 231 | QPainterPath ballPath;
+ | ^~~~~~~~
+../widgets/pixmapdial.cpp:278:26: error: aggregate ‘QPainterPath ballPath’ has incomplete type and cannot be defined
+ 278 | QPainterPath ballPath;
+ | ^~~~~~~~
+
+Signed-off-by: Alex Tsitsimpis <alex.tsitsimpis@gmail.com>
+---
+ c++/widgets/pixmapdial.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/c++/widgets/pixmapdial.cpp b/c++/widgets/pixmapdial.cpp
+index 37dcffd..0b5e0f5 100644
+--- a/c++/widgets/pixmapdial.cpp
++++ b/c++/widgets/pixmapdial.cpp
+@@ -22,6 +22,7 @@
+ #include <QtCore/QTimer>
+ #include <QtGui/QPainter>
+ #include <QtGui/QPaintEvent>
++#include <QtGui/QPainterPath>
+
+ PixmapDial::PixmapDial(QWidget* parent)
+ : QDial(parent),
diff --git a/media-sound/cadence/files/cadence-add-skip-stripping.patch b/media-sound/cadence/files/cadence-add-skip-stripping.patch
deleted file mode 100644
index eacf0c9a431d..000000000000
--- a/media-sound/cadence/files/cadence-add-skip-stripping.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff --git a/c++/Makefile.mk b/c++/Makefile.mk
-index ec92861..8e9998f 100644
---- a/c++/Makefile.mk
-+++ b/c++/Makefile.mk
-@@ -7,7 +7,6 @@
- AR ?= ar
- CC ?= gcc
- CXX ?= g++
--STRIP ?= strip
- WINDRES ?= windres
-
- HOSTBINS = $(shell pkg-config --variable=host_bins Qt5Core)
-@@ -22,7 +21,6 @@ DEBUG ?= false
- ifeq ($(DEBUG),true)
- BASE_FLAGS = -O0 -g -Wall -Wextra
- BASE_FLAGS += -DDEBUG
--STRIP = true # FIXME
- else
- BASE_FLAGS = -O3 -ffast-math -mtune=generic -msse -mfpmath=sse -Wall -Wextra
- BASE_FLAGS += -DNDEBUG
-@@ -38,6 +36,10 @@ ifneq ($(DEBUG),true)
- BUILD_CXX_FLAGS += -DQT_NO_DEBUG -DQT_NO_DEBUG_STREAM -DQT_NO_DEBUG_OUTPUT
- endif
-
-+ifneq ($(SKIP_STRIPPING), true)
-+LINK_FLAGS += -Wl,--strip-all
-+endif
-+
- # --------------------------------------------------------------
-
- # Currently broken
-diff --git a/c++/jackmeter/Makefile b/c++/jackmeter/Makefile
-index 004076d..bfe3230 100644
---- a/c++/jackmeter/Makefile
-+++ b/c++/jackmeter/Makefile
-@@ -31,10 +31,10 @@ OBJS = \
- all: cadence-jackmeter
-
- cadence-jackmeter: $(FILES) $(OBJS)
-- $(CXX) $(OBJS) $(LINK_FLAGS) -ldl -o $@ && $(STRIP) $@
-+ $(CXX) $(OBJS) $(LINK_FLAGS) -ldl -o $@
-
- cadence-jackmeter.exe: $(FILES) $(OBJS) icon.o
-- $(CXX) $(OBJS) icon.o $(LINK_FLAGS) -limm32 -lole32 -luuid -lwinspool -lws2_32 -mwindows -o $@ && $(STRIP) $@
-+ $(CXX) $(OBJS) icon.o $(LINK_FLAGS) -limm32 -lole32 -luuid -lwinspool -lws2_32 -mwindows -o $@
-
- # --------------------------------------------------------------
-
-diff --git a/c++/xycontroller/Makefile b/c++/xycontroller/Makefile
-index 662a7af..b4aac04 100644
---- a/c++/xycontroller/Makefile
-+++ b/c++/xycontroller/Makefile
-@@ -35,10 +35,10 @@ OBJS = xycontroller.o \
- all: cadence-xycontroller
-
- cadence-xycontroller: $(FILES) $(OBJS)
-- $(CXX) $(OBJS) $(LINK_FLAGS) -ldl -o $@ && $(STRIP) $@
-+ $(CXX) $(OBJS) $(LINK_FLAGS) -ldl -o $@
-
- cadence-xycontroller.exe: $(FILES) $(OBJS) icon.o
-- $(CXX) $(OBJS) icon.o $(LINK_FLAGS) -limm32 -lole32 -luuid -lwinspool -lws2_32 -mwindows -o $@ && $(STRIP) $@
-+ $(CXX) $(OBJS) icon.o $(LINK_FLAGS) -limm32 -lole32 -luuid -lwinspool -lws2_32 -mwindows -o $@
-
- # --------------------------------------------------------------
-