summaryrefslogtreecommitdiff
path: root/media-sound/bristol/bristol-0.60.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/bristol/bristol-0.60.11.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/bristol/bristol-0.60.11.ebuild')
-rw-r--r--media-sound/bristol/bristol-0.60.11.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/bristol/bristol-0.60.11.ebuild b/media-sound/bristol/bristol-0.60.11.ebuild
new file mode 100644
index 000000000000..70e8fdeb0cdc
--- /dev/null
+++ b/media-sound/bristol/bristol-0.60.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Synthesizer keyboard emulation package: Moog, Hammond and others"
+HOMEPAGE="https://sourceforge.net/projects/bristol"
+SRC_URI="mirror://sourceforge/bristol/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa oss static-libs"
+# osc : configure option but no code it seems...
+# jack: fails to build if disabled
+# pulseaudio: not fully supported
+
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.109.2
+ alsa? ( >=media-libs/alsa-lib-1.0.0 )
+ x11-libs/libX11"
+# osc? ( >=media-libs/liblo-0.22 )
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog HOWTO NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ epatch "${FILESDIR}"/${P}-implicit-dec.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-version-check \
+ $(use_enable oss) \
+ $(use_enable alsa)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}