summaryrefslogtreecommitdiff
path: root/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /media-sound/bluez-alsa/bluez-alsa-9999.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'media-sound/bluez-alsa/bluez-alsa-9999.ebuild')
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index 8b3787db68d9..186e2b9681cb 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils multilib-minimal
+EAPI=7
+inherit autotools multilib-minimal
DESCRIPTION="Bluetooth Audio ALSA Backend"
HOMEPAGE="https://github.com/Arkq/bluez-alsa"
@@ -29,7 +29,6 @@ RDEPEND=">=dev-libs/glib-2.16[dbus,${MULTILIB_USEDEP}]
sys-libs/ncurses:0=
)"
DEPEND="${RDEPEND}
- net-libs/ortp
virtual/pkgconfig"
src_prepare() {
@@ -38,19 +37,20 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
- $(use_enable aac) \
- $(use_enable debug) \
+ local myeconfargs=(
+ $(use_enable aac)
+ $(use_enable debug)
$(multilib_native_use_enable hcitop)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
default
- prune_libtool_files --modules
+ find "${ED}" -name "*.la" -delete || die
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
- newconfd "${FILESDIR}"/bluealsa-conf.d bluealsa
+ newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
}
pkg_postinst() {