summaryrefslogtreecommitdiff
path: root/media-sound/beets/beets-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-04 00:07:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-04 00:07:50 +0100
commitdafa6f367240d1f5329ca89fb6f78985dbdc025b (patch)
tree96ba5ff3cc1d06604d928ca1b58ed15a4f8733dc /media-sound/beets/beets-9999.ebuild
parenta3bb28551df94028000fb72308a9e9baa01458b0 (diff)
gentoo auto-resync : 04:06:2024 - 00:07:50
Diffstat (limited to 'media-sound/beets/beets-9999.ebuild')
-rw-r--r--media-sound/beets/beets-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/media-sound/beets/beets-9999.ebuild b/media-sound/beets/beets-9999.ebuild
index 4bb022d375b0..00a1c997e652 100644
--- a/media-sound/beets/beets-9999.ebuild
+++ b/media-sound/beets/beets-9999.ebuild
@@ -40,13 +40,14 @@ RDEPEND="
dev-python/munkres[${PYTHON_USEDEP}]
>=media-libs/mutagen-1.33[${PYTHON_USEDEP}]
>=dev-python/musicbrainzngs-0.4[${PYTHON_USEDEP}]
+ dev-python/confuse[${PYTHON_USEDEP}]
+ dev-python/mediafile[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/reflink[${PYTHON_USEDEP}]
dev-python/requests-oauthlib[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
dev-python/unidecode[${PYTHON_USEDEP}]
- dev-python/reflink[${PYTHON_USEDEP}]
- dev-python/confuse[${PYTHON_USEDEP}]
- dev-python/mediafile[${PYTHON_USEDEP}]
')"
DEPEND="
${RDEPEND}
@@ -54,6 +55,7 @@ DEPEND="
BDEPEND="
doc? (
dev-python/sphinx
+ dev-python/pydata-sphinx-theme
)
$(python_gen_cond_dep '
test? (
@@ -109,7 +111,7 @@ src_prepare() {
sed -i -e "/--cov=beets/,+9d" setup.cfg || die "Failed to disable code coverage options in setup.cfg"
# Update the version if we're not building from pypy; it's probably a _pre or live ebuild.
if [[ ${PV} == "9999" ]] || [[ ${UPDATE_VERSION} == "yes" ]]; then
- sed -i -e "s/version=\".*\"/version=\"${PV}\"/" setup.py || die "Failed to update version in VCS sources"
+ sed -i -e "s/version='.*'/version='${PV}'/" setup.py || die "Failed to update version in VCS sources"
sed -i -e "s/__version__ = \".*\"/__version__ = \"${PV}\"/" beets/__init__.py
fi
default
@@ -121,7 +123,7 @@ python_prepare_all() {
python_compile_all() {
if use doc ; then
- sphinx-build -b html docs docs/build || die
+ sphinx-build -b html docs docs/build/html || die
fi
# If building from VCS sources we need to generate manpages, then copy them to ${S}/man
# We could install mans from the sphinx build path, but to be consistent with pypi for src_install