summaryrefslogtreecommitdiff
path: root/media-sound/beets/beets-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
commit5e41a38157bb40e8513e8e34426e85faba672fe7 (patch)
tree38e9365afd56c161d0e970ddf5420b2585130587 /media-sound/beets/beets-9999.ebuild
parent0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (diff)
gentoo auto-resync : 14:06:2024 - 00:09:04
Diffstat (limited to 'media-sound/beets/beets-9999.ebuild')
-rw-r--r--media-sound/beets/beets-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-sound/beets/beets-9999.ebuild b/media-sound/beets/beets-9999.ebuild
index 00a1c997e652..ed8336d62a74 100644
--- a/media-sound/beets/beets-9999.ebuild
+++ b/media-sound/beets/beets-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite"
@@ -108,10 +108,10 @@ src_prepare() {
# https://github.com/beetbox/beets/commit/8b4983fe7cae9397acd3e23602e419d8dc1041d4
# merged code coverage into standard test runs; since we disable coverage globally
# we need to sed out some 'addopts' for coverage in setup.cfg that cause tests to choke.
- sed -i -e "/--cov=beets/,+9d" setup.cfg || die "Failed to disable code coverage options in setup.cfg"
+ #sed -i -e "/--cov=beets/,+9d" setup.cfg || die "Failed to disable code coverage options in setup.cfg"
# Update the version if we're not building from pypy; it's probably a _pre or live ebuild.
if [[ ${PV} == "9999" ]] || [[ ${UPDATE_VERSION} == "yes" ]]; then
- sed -i -e "s/version='.*'/version='${PV}'/" setup.py || die "Failed to update version in VCS sources"
+ sed -i -e "s/^version = \".*\"$/version = \"${PV}\"/" pyproject.toml || die "Failed to update version in VCS sources"
sed -i -e "s/__version__ = \".*\"/__version__ = \"${PV}\"/" beets/__init__.py
fi
default
@@ -141,7 +141,7 @@ python_test() {
local EPYTEST_DESELECT=(
test/test_ui.py::CompletionTest::test_completion
)
- epytest -n$(makeopts_jobs) -v
+ epytest -n$(makeopts_jobs) -v --no-cov
}
python_install_all() {