summaryrefslogtreecommitdiff
path: root/media-sound/aumix/aumix-2.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/aumix/aumix-2.9.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/aumix/aumix-2.9.1.ebuild')
-rw-r--r--media-sound/aumix/aumix-2.9.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/aumix/aumix-2.9.1.ebuild b/media-sound/aumix/aumix-2.9.1.ebuild
new file mode 100644
index 000000000000..08f14da30e30
--- /dev/null
+++ b/media-sound/aumix/aumix-2.9.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Aumix volume/mixer control program"
+HOMEPAGE="http://jpj.net/~trevor/aumix.html"
+SRC_URI="http://jpj.net/~trevor/aumix/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86"
+IUSE="gpm gtk nls"
+
+RDEPEND="sys-libs/ncurses
+ gpm? ( sys-libs/gpm )
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local myconf
+
+ use gtk || myconf="${myconf} --without-gtk"
+ use gpm || myconf="${myconf} --without-gpm"
+
+ econf \
+ $(use_enable nls) \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+
+ newinitd "${FILESDIR}"/aumix.rc6 aumix
+
+ if use gtk; then
+ doicon data/aumix.xpm
+ make_desktop_entry aumix Aumix
+ fi
+}