summaryrefslogtreecommitdiff
path: root/media-sound/aqualung/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/aqualung/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/aqualung/files')
-rw-r--r--media-sound/aqualung/files/aqualung-1.0-ar.patch17
-rw-r--r--media-sound/aqualung/files/aqualung-1.0-gcc10.patch69
2 files changed, 86 insertions, 0 deletions
diff --git a/media-sound/aqualung/files/aqualung-1.0-ar.patch b/media-sound/aqualung/files/aqualung-1.0-ar.patch
new file mode 100644
index 000000000000..3df4d75eaf1b
--- /dev/null
+++ b/media-sound/aqualung/files/aqualung-1.0-ar.patch
@@ -0,0 +1,17 @@
+diff -Naur aqualung-1.0_orig/configure.ac aqualung-1.0/configure.ac
+--- aqualung-1.0_orig/configure.ac 2020-08-05 20:00:50.758797358 +0200
++++ aqualung-1.0/configure.ac 2020-08-05 20:01:33.198796503 +0200
+@@ -25,11 +25,12 @@
+
+
+ # Checks for programs.
++AC_USE_SYSTEM_EXTENSIONS
+ AC_PROG_CC
+ AC_PROG_RANLIB
+ AC_PROG_CXX
+ AM_PROG_CC_C_O
+-AC_USE_SYSTEM_EXTENSIONS
++AM_PROG_AR
+ m4_ifndef([AM_GNU_GETTEXT],
+ [m4_fatal([GNU gettext is required to prepare the Aqualung build])])
+ AM_GNU_GETTEXT([external])
diff --git a/media-sound/aqualung/files/aqualung-1.0-gcc10.patch b/media-sound/aqualung/files/aqualung-1.0-gcc10.patch
new file mode 100644
index 000000000000..620bcb873d95
--- /dev/null
+++ b/media-sound/aqualung/files/aqualung-1.0-gcc10.patch
@@ -0,0 +1,69 @@
+From de448507343a86ee97949eb4be0092d1659092da Mon Sep 17 00:00:00 2001
+From: Adam Sampson <ats@offog.org>
+Date: Sat, 18 Jul 2020 17:02:32 +0100
+Subject: [PATCH 1/2] Remove unused variable.
+
+This causes a duplicate symbol error with GCC 10 (-fno-common by
+default), but it's not used anyway.
+---
+ src/playlist.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/playlist.c b/src/playlist.c
+index 35483d1..96fac75 100644
+--- a/src/playlist.c
++++ b/src/playlist.c
+@@ -134,8 +134,6 @@ GtkWidget * plist__send_songs_to_iriver;
+ GtkWidget * plist__export;
+ #endif /* HAVE_TRANSCODING */
+
+-gchar command[RB_CONTROL_SIZE];
+-
+ GtkTreeIter * fileinfo_iter = NULL;
+
+ int playlist_dirty;
+
+From 7f5d1f266957b3fa73799d3edef6b19ff9716d02 Mon Sep 17 00:00:00 2001
+From: Adam Sampson <ats@offog.org>
+Date: Sat, 18 Jul 2020 17:06:41 +0100
+Subject: [PATCH 2/2] Rename timeout_tag to ports_timeout_tag.
+
+This causes a duplicate symbol error with GCC 10 (-fno-common by
+default), because there's also a global timeout_tag in main.c.
+
+Also correct the type to guint rather than gint.
+---
+ src/ports.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/ports.c b/src/ports.c
+index f17a5ab..f4de59d 100644
+--- a/src/ports.c
++++ b/src/ports.c
+@@ -63,7 +63,7 @@ GtkTreeViewColumn * column_out_R;
+ int n_clients;
+ GtkListStore * store_out_nb[MAX_JACK_CLIENTS];
+
+-gint timeout_tag;
++guint ports_timeout_tag;
+
+ int out_selector = 0;
+
+@@ -242,7 +242,7 @@ tree_out_L_selection_changed(GtkTreeSelection * selection, gpointer * data) {
+ fprintf(stderr, "ERROR: jack_disconnect() returned %d\n", res);
+ }
+ g_free(str);
+- timeout_tag = aqualung_timeout_add(100, ports_timeout_callback, GINT_TO_POINTER(1));
++ ports_timeout_tag = aqualung_timeout_add(100, ports_timeout_callback, GINT_TO_POINTER(1));
+ }
+ }
+
+@@ -262,7 +262,7 @@ tree_out_R_selection_changed(GtkTreeSelection *selection, gpointer * data) {
+ fprintf(stderr, "ERROR: jack_disconnect() returned %d\n", res);
+ }
+ g_free(str);
+- timeout_tag = aqualung_timeout_add(100, ports_timeout_callback, (gpointer)2);
++ ports_timeout_tag = aqualung_timeout_add(100, ports_timeout_callback, (gpointer)2);
+ }
+ }
+