summaryrefslogtreecommitdiff
path: root/media-sound/apetag/apetag-1.12-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/apetag/apetag-1.12-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/apetag/apetag-1.12-r2.ebuild')
-rw-r--r--media-sound/apetag/apetag-1.12-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/apetag/apetag-1.12-r2.ebuild b/media-sound/apetag/apetag-1.12-r2.ebuild
new file mode 100644
index 000000000000..831122cb12a8
--- /dev/null
+++ b/media-sound/apetag/apetag-1.12-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="Command-line ape 2.0 tagger"
+HOMEPAGE="http://muth.org/Robert/Apetag/"
+SRC_URI="http://muth.org/Robert/Apetag/${PN}.${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN^}
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:CXXDEBUG:LDFLAGS:' \
+ Makefile || die
+ python_fix_shebang *.py
+}
+
+src_compile() {
+ tc-export CXX
+ emake \
+ CXXFLAGS="${CXXFLAGS} -Wall -pedantic" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+
+ python_moduleinto /usr/lib/apetag
+ python_domodule *.py
+
+ fperms +x /usr/lib/apetag/{rmid3tag,tagdir}.py
+ dosym ../lib/apetag/rmid3tag.py /usr/bin/rmid3tag.py
+ dosym ../lib/apetag/tagdir.py /usr/bin/tagdir.py
+
+ newdoc 00readme README
+}