summaryrefslogtreecommitdiff
path: root/media-sound/a2jmidid/a2jmidid-9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 19:43:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 19:43:35 +0100
commitb7efdd771aad99c9a6509a5f85a80a1f7cfd55f3 (patch)
tree02f9d01894c5e75c1d01e1c85038384cb6d1da64 /media-sound/a2jmidid/a2jmidid-9-r1.ebuild
parente2e7cc7d880b593b2bc94bf648dff853c97225f2 (diff)
gentoo auto-resync : 30:06:2023 - 19:43:35
Diffstat (limited to 'media-sound/a2jmidid/a2jmidid-9-r1.ebuild')
-rw-r--r--media-sound/a2jmidid/a2jmidid-9-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/a2jmidid/a2jmidid-9-r1.ebuild b/media-sound/a2jmidid/a2jmidid-9-r1.ebuild
new file mode 100644
index 000000000000..6611af19c248
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-9-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit meson python-single-r1
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="https://github.com/jackaudio/a2jmidid"
+SRC_URI="https://github.com/jackaudio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="dbus python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ media-libs/alsa-lib
+ virtual/jack
+ dbus? ( sys-apps/dbus )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst internals.txt )
+
+src_configure() {
+ local emesonargs=(
+ -Ddisable-dbus=$(usex dbus false true)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python; then
+ python_fix_shebang "${ED}"
+ else
+ rm "${ED}/usr/bin/a2j_control" || die
+ fi
+}